aboutsummaryrefslogtreecommitdiffstats
path: root/main/opensmtpd
diff options
context:
space:
mode:
authorCarlo Landmeter <clandmeter@gmail.com>2017-02-10 15:31:30 +0100
committerCarlo Landmeter <clandmeter@gmail.com>2017-02-10 15:31:30 +0100
commitee66511cf98f8e1ac30f4503d807bfb746ee64f5 (patch)
tree5960d64f4ee9f7ac43f17a8e3785d2b497cbd465 /main/opensmtpd
parentdd29f74027d5760c4dd208149badf82e018d0d4f (diff)
downloadaports-ee66511cf98f8e1ac30f4503d807bfb746ee64f5.tar.bz2
aports-ee66511cf98f8e1ac30f4503d807bfb746ee64f5.tar.xz
main/opensmtpd: fix libressl arc4random circularity
Diffstat (limited to 'main/opensmtpd')
-rw-r--r--main/opensmtpd/APKBUILD14
-rw-r--r--main/opensmtpd/opensmtpd-5.7.3p2-libressl-arc4random-circularity.patch35
2 files changed, 44 insertions, 5 deletions
diff --git a/main/opensmtpd/APKBUILD b/main/opensmtpd/APKBUILD
index 3c5c4c3918..c522e50a1a 100644
--- a/main/opensmtpd/APKBUILD
+++ b/main/opensmtpd/APKBUILD
@@ -3,7 +3,7 @@
# Maintainer: Jonathan Curran <jonathan@curran.in>
pkgname=opensmtpd
pkgver=5.9.2p1
-pkgrel=2
+pkgrel=3
pkgdesc="secure, reliable, lean, and easy-to configure SMTP server"
url="http://www.opensmtpd.org"
arch="all"
@@ -16,7 +16,8 @@ install="$pkgname.pre-install $pkgname.post-install"
subpackages="$pkgname-doc"
source="https://www.opensmtpd.org/archives/${pkgname}-${pkgver}.tar.gz
smtpd.initd
- aliases"
+ aliases
+ opensmtpd-5.7.3p2-libressl-arc4random-circularity.patch"
options="suid"
builddir="$srcdir"/$pkgname-$pkgver
@@ -55,10 +56,13 @@ package() {
md5sums="d109374dcc4bc8be14f790b859f1dd31 opensmtpd-5.9.2p1.tar.gz
a2f311a82c9a85f5c52975c4dbbdbd53 smtpd.initd
-561d2aead043a64a4ce5d66b4f78223e aliases"
+561d2aead043a64a4ce5d66b4f78223e aliases
+a4c72a6a5fe18b514571e4baac19756f opensmtpd-5.7.3p2-libressl-arc4random-circularity.patch"
sha256sums="3522f273c1630c781facdb2b921228e338ed4e651909316735df775d6a70a71d opensmtpd-5.9.2p1.tar.gz
ab4b7f066a38dadd7a2dc6d7c3a06c3a8ac2367340d97e2a8b54f571ea0f8cf8 smtpd.initd
-7bef80f8d86aa5463c864681482a4908d22ff8b6f3e47d2a410ef2d59b316b53 aliases"
+7bef80f8d86aa5463c864681482a4908d22ff8b6f3e47d2a410ef2d59b316b53 aliases
+0dee9bb91e191bfe51e8609c9469cc141af1b1c049869db4eebbf0bbb55971f6 opensmtpd-5.7.3p2-libressl-arc4random-circularity.patch"
sha512sums="99ca15101557848aa6d642f0c0171b152d805192e6839a97410b19431c981a21a5c0dc011e2c8cd91f3e6f6acb37a77f0f4c8e68114bf9808240392fe2b5d375 opensmtpd-5.9.2p1.tar.gz
8152fecadeb1d818b7865eae040123f855e81fafbb4b40d12a64336e09dc486c10e6828809182c8172bfd9f54dc7d050a154b61d5e6049df6ffd8a7b6e5e1277 smtpd.initd
-929ba0b8befca6cad558602f9793a9c653923924ee524902916b8ef4952d1ea8a391895e7450ed9768eb82a07bd307b49561f5d49ea4711bd87a1a73eb8d7dad aliases"
+929ba0b8befca6cad558602f9793a9c653923924ee524902916b8ef4952d1ea8a391895e7450ed9768eb82a07bd307b49561f5d49ea4711bd87a1a73eb8d7dad aliases
+f1958f86edbf558bac88f944196670b4d34b7367f8479ef13433981bcb174afd7aa0e42aa447eac4bd46b0be849e2cf97313cc1073782c86c4c0a4aa7326b456 opensmtpd-5.7.3p2-libressl-arc4random-circularity.patch"
diff --git a/main/opensmtpd/opensmtpd-5.7.3p2-libressl-arc4random-circularity.patch b/main/opensmtpd/opensmtpd-5.7.3p2-libressl-arc4random-circularity.patch
new file mode 100644
index 0000000000..7c35862914
--- /dev/null
+++ b/main/opensmtpd/opensmtpd-5.7.3p2-libressl-arc4random-circularity.patch
@@ -0,0 +1,35 @@
+diff -ru opensmtpd-5.7.3p2/openbsd-compat/arc4random.c opensmtpd-5.7.3p2-fixed/openbsd-compat/arc4random.c
+--- opensmtpd-5.7.3p2/openbsd-compat/arc4random.c 2016-02-02 08:40:06.000000000 +0100
++++ opensmtpd-5.7.3p2-fixed/openbsd-compat/arc4random.c 2016-03-02 17:34:24.535030362 +0100
+@@ -188,6 +188,7 @@
+ _ARC4_UNLOCK();
+ }
+
++#if 0
+ u_int32_t
+ arc4random(void)
+ {
+@@ -198,12 +199,13 @@
+ _ARC4_UNLOCK();
+ return val;
+ }
++#endif
+
+ /*
+ * If we are providing arc4random, then we can provide a more efficient
+ * arc4random_buf().
+ */
+-# ifndef HAVE_ARC4RANDOM_BUF
++#if 0
+ void
+ arc4random_buf(void *buf, size_t n)
+ {
+@@ -215,7 +217,7 @@
+ #endif /* !HAVE_ARC4RANDOM */
+
+ /* arc4random_buf() that uses platform arc4random() */
+-#if !defined(HAVE_ARC4RANDOM_BUF) && defined(HAVE_ARC4RANDOM)
++#if 0
+ void
+ arc4random_buf(void *_buf, size_t n)
+ {