aboutsummaryrefslogtreecommitdiffstats
path: root/main/openssl/0005-fix-parallel-build.patch
diff options
context:
space:
mode:
authorTimo Teräs <timo.teras@iki.fi>2015-07-09 16:36:33 +0300
committerTimo Teräs <timo.teras@iki.fi>2015-07-09 16:40:50 +0300
commit4cc1178d550587aaaf640ef084feeadb2e751b80 (patch)
tree83b5c1cb0a2c59f114f92f6a07f09c68b1d3902f /main/openssl/0005-fix-parallel-build.patch
parente24406612af6110fe7e2c881a6532c725dfb249e (diff)
downloadaports-4cc1178d550587aaaf640ef084feeadb2e751b80.tar.bz2
aports-4cc1178d550587aaaf640ef084feeadb2e751b80.tar.xz
main/openssl: security upgrade to 1.0.1d (CVE-2015-1793)
Diffstat (limited to 'main/openssl/0005-fix-parallel-build.patch')
-rw-r--r--main/openssl/0005-fix-parallel-build.patch33
1 files changed, 14 insertions, 19 deletions
diff --git a/main/openssl/0005-fix-parallel-build.patch b/main/openssl/0005-fix-parallel-build.patch
index 24bc5d643e..70073fd195 100644
--- a/main/openssl/0005-fix-parallel-build.patch
+++ b/main/openssl/0005-fix-parallel-build.patch
@@ -1,31 +1,26 @@
diff -ru openssl-1.0.2a.orig/Makefile.org openssl-1.0.2a/Makefile.org
---- openssl-1.0.2a.orig/Makefile.org 2015-03-19 13:30:36.000000000 +0000
-+++ openssl-1.0.2a/Makefile.org 2015-03-19 14:53:31.246908039 +0000
-@@ -274,17 +274,17 @@
- build_libs: build_crypto build_ssl build_engines
+--- openssl-1.0.2d.orig/Makefile.org 2015-07-09 16:30:50.201986573 -0300
++++ openssl-1.0.2d/Makefile.org 2015-07-09 16:30:50.201986573 -0300
+@@ -278,17 +278,17 @@
+ build_libssl: build_ssl libssl.pc
build_crypto:
- @dir=crypto; target=all; $(BUILD_ONE_CMD)
--build_ssl:
-- @dir=ssl; target=all; $(BUILD_ONE_CMD)
--build_engines:
-- @dir=engines; target=all; $(BUILD_ONE_CMD)
--build_apps:
-- @dir=apps; target=all; $(BUILD_ONE_CMD)
--build_tests:
-- @dir=test; target=all; $(BUILD_ONE_CMD)
--build_tools:
-- @dir=tools; target=all; $(BUILD_ONE_CMD)
+ +@dir=crypto; target=all; $(BUILD_ONE_CMD)
-+build_ssl: build_crypto
+ build_ssl: build_crypto
+- @dir=ssl; target=all; $(BUILD_ONE_CMD)
+ +@dir=ssl; target=all; $(BUILD_ONE_CMD)
-+build_engines: build_crypto
+ build_engines: build_crypto
+- @dir=engines; target=all; $(BUILD_ONE_CMD)
+ +@dir=engines; target=all; $(BUILD_ONE_CMD)
-+build_apps: build_libs
+ build_apps: build_libs
+- @dir=apps; target=all; $(BUILD_ONE_CMD)
+ +@dir=apps; target=all; $(BUILD_ONE_CMD)
-+build_tests: build_libs
+ build_tests: build_libs
+- @dir=test; target=all; $(BUILD_ONE_CMD)
+ +@dir=test; target=all; $(BUILD_ONE_CMD)
-+build_tools: build_libs
+ build_tools: build_libs
+- @dir=tools; target=all; $(BUILD_ONE_CMD)
+ +@dir=tools; target=all; $(BUILD_ONE_CMD)
all_testapps: build_libs build_testapps