aboutsummaryrefslogtreecommitdiffstats
path: root/main/openssl/APKBUILD
diff options
context:
space:
mode:
authorBartłomiej Piotrowski <bpiotrowski@alpinelinux.org>2014-10-12 16:07:36 +0200
committerBartłomiej Piotrowski <bpiotrowski@alpinelinux.org>2014-10-12 16:08:08 +0200
commit55be35964fbada2bef285e687b7e0cf84977566b (patch)
tree86c9453dc71d741356410b595d25d86a3613abc7 /main/openssl/APKBUILD
parent12820b2c6dd828455b6def5ec19a12fedd9502dd (diff)
downloadaports-55be35964fbada2bef285e687b7e0cf84977566b.tar.bz2
aports-55be35964fbada2bef285e687b7e0cf84977566b.tar.xz
main/openssl: enable accelerated NIST P-224 and P-256 on x86_64
Diffstat (limited to 'main/openssl/APKBUILD')
-rw-r--r--main/openssl/APKBUILD7
1 files changed, 4 insertions, 3 deletions
diff --git a/main/openssl/APKBUILD b/main/openssl/APKBUILD
index 87da75d524..24ee11ee43 100644
--- a/main/openssl/APKBUILD
+++ b/main/openssl/APKBUILD
@@ -1,7 +1,7 @@
# Maintainer: Timo Teras <timo.teras@iki.fi>
pkgname=openssl
pkgver=1.0.1i
-pkgrel=2
+pkgrel=3
pkgdesc="Toolkit for SSL v2/v3 and TLS v1"
url="http://openssl.org"
depends=
@@ -60,7 +60,7 @@ prepare() {
}
build() {
- local _target
+ local _target _optflags
cd "$_builddir"
# openssl will prepend crosscompile always core CC et al
@@ -71,7 +71,7 @@ build() {
# determine target OS for openssl
case "$CARCH" in
x86) _target="linux-elf" ;;
- x86_64) _target="linux-x86_64" ;;
+ x86_64) _target="linux-x86_64"; _optflags="enable-ec_nistp_64_gcc_128" ;;
arm*) _target="linux-armv4" ;;
*) msg "Unable to determine architecture from (CARCH=$CARCH)" ; return 1 ;;
esac
@@ -86,6 +86,7 @@ build() {
shared zlib enable-montasm enable-md2 \
-DOPENSSL_NO_BUF_FREELISTS \
-Wa,--noexecstack \
+ $_optflags \
|| return 1
make && make build-shared || return 1