aboutsummaryrefslogtreecommitdiffstats
path: root/main/openssl
diff options
context:
space:
mode:
authorBreno Leitao <brenohl@br.ibm.com>2017-01-18 13:37:23 -0500
committerTimo Teräs <timo.teras@iki.fi>2017-01-27 16:50:10 +0200
commit0e851600ef891ec5ca09cd02e4a54f14ff29f28a (patch)
tree6537042e691f943a1bf873b6366b6600bb96c59b /main/openssl
parent2cc0cb10994427714b2379e024c2233852215cb5 (diff)
downloadaports-0e851600ef891ec5ca09cd02e4a54f14ff29f28a.tar.bz2
aports-0e851600ef891ec5ca09cd02e4a54f14ff29f28a.tar.xz
main/openssl: Add support for ppc64le
This patch adds a target for ppc64le architecture. The target name on OpenSSL linux-ppc64le.
Diffstat (limited to 'main/openssl')
-rw-r--r--main/openssl/APKBUILD1
1 files changed, 1 insertions, 0 deletions
diff --git a/main/openssl/APKBUILD b/main/openssl/APKBUILD
index 0e9c99c47e..49ffa89b2d 100644
--- a/main/openssl/APKBUILD
+++ b/main/openssl/APKBUILD
@@ -67,6 +67,7 @@ build() {
case "$CARCH" in
aarch64*) _target="linux-aarch64" ;;
arm*) _target="linux-armv4" ;;
+ ppc64le) _target="linux-ppc64le" ;;
x86) _target="linux-elf" ;;
x86_64) _target="linux-x86_64"; _optflags="enable-ec_nistp_64_gcc_128" ;;
*) msg "Unable to determine architecture from (CARCH=$CARCH)" ; return 1 ;;