aboutsummaryrefslogtreecommitdiffstats
path: root/main/openvswitch
diff options
context:
space:
mode:
authorStuart Cardall <developer@it-offshore.co.uk>2016-09-28 20:28:07 +0000
committerJakub Jirutka <jakub@jirutka.cz>2016-09-28 23:21:49 +0200
commit37504e4898503d315252c439ab6bb250a198d2e2 (patch)
treedf73de836419374bc779a223802e28028e1f3c1c /main/openvswitch
parentbc2fd727007d18814c28cd6d0df7453d6b23e8be (diff)
downloadaports-37504e4898503d315252c439ab6bb250a198d2e2.tar.bz2
aports-37504e4898503d315252c439ab6bb250a198d2e2.tar.xz
main/openvswitch: update to 2.6.0
the stack size in lib/ovs-thread.c is now set to 512 bytes by ovs so the patch is no longer needed. http://openvswitch.org/releases/NEWS-2.6.0
Diffstat (limited to 'main/openvswitch')
-rw-r--r--main/openvswitch/0001-ovs-thread-Set-stacksize-to-1M.patch60
-rw-r--r--main/openvswitch/0002-fix-wait-any.patch10
-rw-r--r--main/openvswitch/APKBUILD54
3 files changed, 24 insertions, 100 deletions
diff --git a/main/openvswitch/0001-ovs-thread-Set-stacksize-to-1M.patch b/main/openvswitch/0001-ovs-thread-Set-stacksize-to-1M.patch
deleted file mode 100644
index 2a7ae57b30..0000000000
--- a/main/openvswitch/0001-ovs-thread-Set-stacksize-to-1M.patch
+++ /dev/null
@@ -1,60 +0,0 @@
-From 92ae6e162812876c082fd9d05a0eeac062f832ae Mon Sep 17 00:00:00 2001
-From: Natanael Copa <ncopa@alpinelinux.org>
-Date: Mon, 25 Aug 2014 08:50:26 +0000
-Subject: [PATCH] ovs-thread: Set stacksize to 1M
-
-With musl libc the default stacksize is 80k which is too small and
-makes it segfault.
-
-We increase it to 1MB.
-http://permalink.gmane.org/gmane.linux.network.openvswitch.general/5831
-
-Signed-off-by: Natanael Copa <ncopa@alpinelinux.org>
----
- lib/ovs-thread.c | 15 +++++++++++++++
- 1 file changed, 15 insertions(+)
-
-diff -ru openvswitch-2.3.0.orig/lib/ovs-thread.c openvswitch-2.3.0/lib/ovs-thread.c
---- openvswitch-2.3.0.orig/lib/ovs-thread.c 2014-10-02 14:37:47.196714056 -0300
-+++ openvswitch-2.3.0/lib/ovs-thread.c 2014-10-02 14:38:10.826714288 -0300
-@@ -28,6 +28,9 @@
- #include "socket-util.h"
- #include "util.h"
-
-+/* set default stack size to 1M */
-+#define OVS_STACK_SIZE (1024 * 1024)
-+
- #ifdef __CHECKER__
- /* Omit the definitions in this file because they are somewhat difficult to
- * write without prompting "sparse" complaints, without ugliness or
-@@ -329,6 +332,7 @@
- {
- struct ovsthread_aux *aux;
- pthread_t thread;
-+ pthread_attr_t attr;
- int error;
-
- forbid_forking("multiple threads exist");
-@@ -340,10 +344,21 @@
- aux->arg = arg;
- ovs_strlcpy(aux->name, name, sizeof aux->name);
-
-- error = pthread_create(&thread, NULL, ovsthread_wrapper, aux);
-+ error = pthread_attr_init(&attr);
-+ if (error) {
-+ ovs_abort(error, "pthread_attr_init failed");
-+ }
-+ error = pthread_attr_setstacksize(&attr, OVS_STACK_SIZE);
-+ if (error) {
-+ ovs_abort(error, "pthread_attr_setstacksize failed");
-+ }
-+
-+ error = pthread_create(&thread, &attr, ovsthread_wrapper, aux);
- if (error) {
- ovs_abort(error, "pthread_create failed");
- }
-+ pthread_attr_destroy(&attr);
-+
- return thread;
- }
-
diff --git a/main/openvswitch/0002-fix-wait-any.patch b/main/openvswitch/0002-fix-wait-any.patch
index 085fa36f4b..a4f731da29 100644
--- a/main/openvswitch/0002-fix-wait-any.patch
+++ b/main/openvswitch/0002-fix-wait-any.patch
@@ -5,9 +5,9 @@ See:
http://pubs.opengroup.org/onlinepubs/9699919799/functions/waitpid.html
http://pubs.opengroup.org/onlinepubs/9699919799/basedefs/sys_wait.h.html
---- openvswitch-2.5.0/tests/test-ovn.c
-+++ openvswitch-2.5.0/tests/test-ovn.c.new
-@@ -19,6 +19,11 @@
+--- openvswitch-2.6.0/tests/test-ovn.c
++++ openvswitch-2.6.0/tests/test-ovn.c.new
+@@ -18,6 +18,11 @@
#include <errno.h>
#include <getopt.h>
#include <sys/wait.h>
@@ -16,6 +16,6 @@ http://pubs.opengroup.org/onlinepubs/9699919799/basedefs/sys_wait.h.html
+#define WAIT_ANY (-1)
+#endif
+
- #include "dynamic-string.h"
+ #include "command-line.h"
#include "fatal-signal.h"
- #include "match.h"
+ #include "flow.h"
diff --git a/main/openvswitch/APKBUILD b/main/openvswitch/APKBUILD
index 25e5512d53..4b185a69b8 100644
--- a/main/openvswitch/APKBUILD
+++ b/main/openvswitch/APKBUILD
@@ -1,7 +1,7 @@
# Contributor: Stuart Cardall <developer@it-offshore.co.uk>
# Maintainer: Stuart Cardall <developer@it-offshore.co.uk>
pkgname=openvswitch
-pkgver=2.5.0
+pkgver=2.6.0
pkgrel=0
pkgdesc="A production quality, multilayer virtual switch"
url="http://openvswitch.org/"
@@ -9,7 +9,7 @@ arch="all"
license="ASL 2.0"
depends=""
depends_dev="openssl-dev"
-makedepends="$depends_dev perl python linux-headers bash"
+makedepends="$depends_dev perl python linux-headers bash py-six"
subpackages="$pkgname-doc $pkgname-dbg $pkgname-dev $pkgname-monitor $pkgname-bash-completion:bashcomp"
source="http://openvswitch.org/releases/$pkgname-$pkgver.tar.gz
ovsdb-server.initd
@@ -18,27 +18,14 @@ source="http://openvswitch.org/releases/$pkgname-$pkgver.tar.gz
ovs-vswitchd.confd
ovs-modules.initd
musl-if_packet.patch
- 0001-ovs-thread-Set-stacksize-to-1M.patch
0002-fix-wait-any.patch
ifupdown-alpine.patch
readme.debian.patch
"
-
-_builddir="$srcdir"/$pkgname-$pkgver
-
-prepare() {
- local i
- cd "$_builddir"
-
- for i in $source; do
- case $i in
- *.patch) msg $i; patch -p1 -i "$srcdir"/$i || return 1;;
- esac
- done
-}
+builddir="$srcdir/$pkgname-$pkgver"
build() {
- cd "$_builddir"
+ cd "$builddir"
./configure --prefix=/usr \
--sysconfdir=/etc \
--mandir=/usr/share/man \
@@ -59,7 +46,7 @@ monitor() {
}
package() {
- cd "$_builddir"
+ cd "$builddir"
make DESTDIR="$pkgdir" install || return 1
rm -f "$pkgdir"/usr/lib/*.a
install -Dm755 "$srcdir"/ovsdb-server.initd \
@@ -81,50 +68,47 @@ package() {
"$pkgdir"/etc/network/if-post-down.d/openvswitch || return 1
mkdir -p "$pkgdir"/usr/share/doc/openvswitch || return 1
install -m644 debian/openvswitch-switch.README.Debian \
- "$pkgdir"/usr/share/doc/openvswitch/README.alpine || return 1
+ "$pkgdir"/usr/share/doc/openvswitch/README.alpine || return 1
}
bashcomp() {
- depends=""
- pkgdesc="Bash completions for $pkgname"
- install_if="$pkgname=$pkgver-r$pkgrel bash-completion"
- arch="noarch"
+ depends=""
+ pkgdesc="Bash completions for $pkgname"
+ install_if="$pkgname=$pkgver-r$pkgrel bash-completion"
+ arch="noarch"
- mkdir -p "$subpkgdir"/usr/share/bash-completion/completions/$pkgname
- mv "$_builddir"/utilities/*-bashcomp.bash \
- "$subpkgdir"/usr/share/bash-completion/completions/$pkgname/ || return 1
+ mkdir -p "$subpkgdir"/usr/share/bash-completion/completions/$pkgname
+ mv "$builddir"/utilities/*-bashcomp.bash \
+ "$subpkgdir"/usr/share/bash-completion/completions/$pkgname/ || return 1
}
-md5sums="d86045933aa8f582f1d74ab77f998e44 openvswitch-2.5.0.tar.gz
+md5sums="7d73a3e48aa60a807663e690c3928d72 openvswitch-2.6.0.tar.gz
a2b05882127059f79a02d1c49b58e526 ovsdb-server.initd
f10a8ac784654bec359bda52779f16fe ovsdb-server.confd
384ad5bbe9dd788de78012864233a756 ovs-vswitchd.initd
2d1e0111ea62779f49e14d62678294b2 ovs-vswitchd.confd
45b381d434ccbc634a3224c5963edc66 ovs-modules.initd
58bee4f4b4e632f2af74b91e27f68b5d musl-if_packet.patch
-59fa9a6d293a25571562a5190ae559f2 0001-ovs-thread-Set-stacksize-to-1M.patch
-56ca9845f6729a35ca780fffc47322d9 0002-fix-wait-any.patch
+231d6ed3aa28b007c1c5a88722e8c222 0002-fix-wait-any.patch
85d556990605747b2e5ddf782e2406db ifupdown-alpine.patch
7f8fe9a891992bebf476a58122dabd60 readme.debian.patch"
-sha256sums="34da54fbad503205b1a66b48ca4312679e1ce5b04763a9fb86050b2b25d66f21 openvswitch-2.5.0.tar.gz
+sha256sums="c6f86b47b5847e739ca1c5a80059a804cd49e2b98eefef0fdbce1c4d93c7d0f1 openvswitch-2.6.0.tar.gz
737be74a4ce951cd49b9cd85696ff5cbdb54fa7ad52c831494fcf336487fc420 ovsdb-server.initd
d0d8a6a7256f4cc47ab1b9f9f7657202388133bcfff3668e7c1d4adbcc572261 ovsdb-server.confd
d2db312103d740fb9246ea218560995b969cb8356e3524d4c0ce79a06ccc65b8 ovs-vswitchd.initd
cc189d5ca24708ff775a4de312df3f611c65714724b8901ec6527c9e3f22e14a ovs-vswitchd.confd
06079771a94dd363218f2b3561efd0178a47d85bfd73c8b6cf24eef4ec82b0de ovs-modules.initd
ccd08d23963f3a3ac153df0746a117eea8544aa77f4adfa8f86dc5e22640a5f6 musl-if_packet.patch
-faf997814e89b0b5948c06050ef38051f0bc6b108958f76313263f77a724906c 0001-ovs-thread-Set-stacksize-to-1M.patch
-1343d42be0dfc5fd77afd75269e85a0d65b0f23d0791138dd466f8d9a2081907 0002-fix-wait-any.patch
+22f7a0fded82bf7b96ff258e9dd37a23851b4f1fa18e55b53da1a72a179b1fa7 0002-fix-wait-any.patch
ac312e42b5d47137f860091ad041e7486107ba7956d37cd5a5c91893f7b8a3b3 ifupdown-alpine.patch
942c34f14f6c6db92e2afe20c94fe6302bbb5e41eba2391713f908de101a5177 readme.debian.patch"
-sha512sums="32addb6ed8d4b78e6eb5b951de6b2390dacb3a66096ff8de6020e6d42d460e1038eec43c4057707942f8043ebcad848488d09c7aabfa4599d53782a9cc69f089 openvswitch-2.5.0.tar.gz
+sha512sums="7bcf02a00b94924e7931642790f40a49b86338baa63405e9454bff20b82d5a53bbc43279c223946f082d050c73ce6caedcb8a1e52979c873262bc9e8ff84b42d openvswitch-2.6.0.tar.gz
097d4721a78fff749c534910d98543778474406bd61b469b88a0d981a2a380556444437ec44278cead6d8688c45a38b2acbf1551acb9ab38d048f413728e3b88 ovsdb-server.initd
b1588d076bbfc7ef2dd46fce8e46186f40cbbc4667697f7ac13ddc68e34568fdab315fde47838de7f6d32916853190336cfe3735f672ad7cb624ae14dbff55a5 ovsdb-server.confd
4bff37f8bed32d5327b4b0433984ab8ffdce77f618034aa6ffd1ad4a7caa00703ea2bef312876dce5aafa4c17fe06dddd75e5c05c10e13bf8f5c3805a0654a96 ovs-vswitchd.initd
346aea099f51707d2b4fc9fdc8c1502582723fb4e00c4d5d1624b0378c94dfb76674fa95e2af894f36169df52109dbe441ee6a45aa744584d9e4c74d15a46c1d ovs-vswitchd.confd
614c86eab826bb8f934cf4a98508fde9952a0b7211414e074510473af3455077a333729aa0e59f3634b9bf30d64847d0f7597246506c36a8f09d57573a2522fc ovs-modules.initd
c5f137bce28bf80c1e5a6ca18722dae9a5ecff03d20bf92642270951bbbb499e5fb05a08163442720e866d135fcd7426b88add0b42ed240d5f0c068aa9fcd9da musl-if_packet.patch
-5fed04e68b58ab322154fa1cc4c4b63b08c22ed41f0b7713dbe8437f7cb4e9fd93c8aba524c2e5a46bba956da9439f5bfe5ba6fcdff2b98fa9bbcc748c5b64db 0001-ovs-thread-Set-stacksize-to-1M.patch
-c785a3cdecd40882f9a11e1822e9fda925e68ff79a6e57a79affeb692c1eeaceedb22e6f20ea721f4216c3b06de9f4579ffcf2058cf516b3007aa2a46a166f38 0002-fix-wait-any.patch
+973e1e188c23981114c5120d04cf39bec4597349d4c60056cc3834aa8148cd7bafea6216b0649db3dbd0ea540f8876bfaac90262e9a493abf2faf660c4dda01e 0002-fix-wait-any.patch
0f2847986783f020f0708f2b185f10d1d34ead679bcae553a42df34a244c815e6e7346a2d73af69aff86258ecb3c855630a99ec28c6c7567bcfeacfb5379e5ee ifupdown-alpine.patch
346f11a81f1538513151ea328fcbf2cdfc3c864aa34ea522055bc70266b9b2b2e05bdc0691593a9a1e4ef360d89d465507623edbcd9f764e3707d852736c895c readme.debian.patch"