aboutsummaryrefslogtreecommitdiffstats
path: root/main/ortp/APKBUILD
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2011-08-10 09:07:35 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2011-08-10 12:46:49 +0000
commit9ef72de4812339d34f1e4c5b189d813892484ecf (patch)
treea63debd4dafa0dfa83764bf9bdc1e7abd7852167 /main/ortp/APKBUILD
parentfcb175a506839b40c111af26ae5f99e9a313338a (diff)
downloadaports-9ef72de4812339d34f1e4c5b189d813892484ecf.tar.bz2
aports-9ef72de4812339d34f1e4c5b189d813892484ecf.tar.xz
main/ortp: moved from testing
Diffstat (limited to 'main/ortp/APKBUILD')
-rw-r--r--main/ortp/APKBUILD47
1 files changed, 47 insertions, 0 deletions
diff --git a/main/ortp/APKBUILD b/main/ortp/APKBUILD
new file mode 100644
index 0000000000..bc419952a4
--- /dev/null
+++ b/main/ortp/APKBUILD
@@ -0,0 +1,47 @@
+# Contributor: Natanael Copa <ncopa@alpinelinux.org>
+# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
+pkgname=ortp
+pkgver=0.16.1
+pkgrel=0
+pkgdesc="A C library implementing the RTP protocol (RFC3550)"
+url="http://www.linphone.org/index.php/code_review/ortp"
+arch="all"
+license="LGPLv2+ VSL"
+depends=""
+makedepends=""
+install=""
+subpackages="$pkgname-dev"
+source="http://nongnu.askapache.com/linphone/ortp/sources/ortp-$pkgver.tar.gz
+ ortp-0.16.1-retval.patch
+ ortp-0.16.1-unusedvar.patch
+ "
+
+_builddir="$srcdir"/ortp-$pkgver
+prepare() {
+ local i
+ cd "$_builddir"
+ for i in $source; do
+ case $i in
+ *.patch) msg $i; patch -p1 -i "$srcdir"/$i || return 1;;
+ esac
+ done
+}
+
+build() {
+ cd "$_builddir"
+ ./configure --prefix=/usr \
+ --disable-static \
+ --enable-ipv6 \
+ || return 1
+ make || return 1
+}
+
+package() {
+ cd "$_builddir"
+ make DESTDIR="$pkgdir" install || return 1
+ rm -f "$pkgdir"/usr/lib/*.la
+}
+
+md5sums="bc96cdcb9c139d366a720a94200f92dd ortp-0.16.1.tar.gz
+cdd971e04073b3de2e935e6ff502110f ortp-0.16.1-retval.patch
+f3323a01f3d82279c3ce5ed1bb1969c5 ortp-0.16.1-unusedvar.patch"