aboutsummaryrefslogtreecommitdiffstats
path: root/main/patch
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2018-09-03 17:31:32 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2018-09-03 17:34:59 +0000
commit5251e5507c9726614be9b08fb3b4582d9932d9b2 (patch)
tree984983e1a9eeecbd6f6c9966c65ca725cbb0d7e7 /main/patch
parentf37ce49e6ed16f375749bfd5ed3bede5c0547108 (diff)
downloadaports-5251e5507c9726614be9b08fb3b4582d9932d9b2.tar.bz2
aports-5251e5507c9726614be9b08fb3b4582d9932d9b2.tar.xz
main/patch: avoid using broken code in cross build
The configure cross-compile logic fails to detect no-clobber properties of gettimeofday and tzset functions and replaces them and some dependent calls with the code from the bundled GNU portability library.
Diffstat (limited to 'main/patch')
-rw-r--r--main/patch/APKBUILD4
1 files changed, 3 insertions, 1 deletions
diff --git a/main/patch/APKBUILD b/main/patch/APKBUILD
index 54993e4656..d07ce9abc8 100644
--- a/main/patch/APKBUILD
+++ b/main/patch/APKBUILD
@@ -2,7 +2,7 @@
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=patch
pkgver=2.7.6
-pkgrel=2
+pkgrel=3
pkgdesc="Utility to apply diffs to files"
url="https://www.gnu.org/software/patch/patch.html"
arch="all"
@@ -25,6 +25,8 @@ builddir="$srcdir"/$pkgname-$pkgver
build() {
cd "$builddir"
+ gl_cv_func_gettimeofday_clobber=no \
+ gl_cv_func_tzset_clobber=no \
./configure \
--build=$CBUILD \
--host=$CHOST \