aboutsummaryrefslogtreecommitdiffstats
path: root/main/patchwork/APKBUILD
diff options
context:
space:
mode:
authorCarlo Landmeter <clandmeter@alpinelinux.org>2018-01-30 23:40:17 +0000
committerCarlo Landmeter <clandmeter@alpinelinux.org>2018-01-30 23:40:17 +0000
commitd0d2c8164b2266ac86642397ba19baed2e6a5f55 (patch)
tree772b71c461dd0dba2ae02a960212bfaa11dc6d9f /main/patchwork/APKBUILD
parent8b198b0998db2476459d39307b6b2996737a4298 (diff)
downloadaports-d0d2c8164b2266ac86642397ba19baed2e6a5f55.tar.bz2
aports-d0d2c8164b2266ac86642397ba19baed2e6a5f55.tar.xz
main/patchwork: move to community
Diffstat (limited to 'main/patchwork/APKBUILD')
-rw-r--r--main/patchwork/APKBUILD82
1 files changed, 0 insertions, 82 deletions
diff --git a/main/patchwork/APKBUILD b/main/patchwork/APKBUILD
deleted file mode 100644
index 787d0f3012..0000000000
--- a/main/patchwork/APKBUILD
+++ /dev/null
@@ -1,82 +0,0 @@
-# Con#tributor: Francesco Colista <fcolista@alpinelinux.org>
-# Maintainer: Francesco Colista <fcolista@alpinelinux.org>
-pkgname=patchwork
-pkgver=2.0.1
-pkgrel=0
-pkgdesc="Web-based patch tracking system"
-url="https://github.com/getpatchwork/patchwork"
-arch="noarch"
-license="GPL"
-depends="py-django py-django-registration git py-psycopg2"
-subpackages="$pkgname-doc $pkgname-uwsgi-apache2:apache2_wsgi $pkgname-uwsgi-nginx:nginx_wsgi $pkgname-mysql
- $pkgname-postgresql pwclient:pwclient"
-source="$pkgname-$pkgver.tar.gz::https://github.com/getpatchwork/$pkgname/archive/v$pkgver.tar.gz
- 0001-support-busybox-readlink.patch
- 0002-remove-uneeded-bashism-from-tools-and-change-path.patch
- nginx-uwsgi-patchwork-conf.ini
- nginx-patchwork.conf"
-
-builddir="$srcdir"/$pkgname-$pkgver
-
-build() {
- cd "$builddir"
- return 0
-}
-
-package() {
- cd "$builddir"
- mkdir -p "$pkgdir"/usr/share/webapps/$pkgname
- install -Dm644 COPYING \
- "$pkgdir"/usr/share/doc/$pkgname/COPYING
- rm -f COPYING
- install -Dm644 patchwork/settings/production.example.py \
- "$pkgdir"/etc/$pkgname/production.py
- mv * "$pkgdir"/usr/share/webapps/$pkgname
- cd "$pkgdir"/usr/share/webapps/patchwork/patchwork/settings
- ln -sf /etc/patchwork/production.py
-}
-
-apache2_wsgi() {
- pkgdesc="$pkgname apache2 wsgi support"
- depends="apache2 apache2-mod-wsgi"
- replaces="$pkgname-apache2-wsgi"
- install_if="$pkgname=$pkgver-r$pkgrel apache2-mod-wsgi"
- install -Dm644 "$pkgdir"/usr/share/webapps/patchwork/lib/apache2/patchwork.wsgi.conf \
- "$subpkgdir"/etc/apache2/conf.d/patchwork.wsgi.conf
-}
-
-nginx_wsgi() {
- pkgdesc="$pkgname nginx wsgi support"
- depends="nginx uwsgi-python"
- replaces="$pkgname-nginx_wsgi"
- install_if="nginx patchwork uwsgi"
- install -Dm644 "$srcdir"/nginx-patchwork.conf \
- "$subpkgdir"/etc/nginx/conf.d/patchwork.conf
- install -Dm644 "$srcdir"/nginx-uwsgi-patchwork-conf.ini \
- "$subpkgdir"/etc/uwsgi/conf.d/patchwork.ini
-}
-
-mysql() {
- pkgdesc="$pkgname mysql support"
- depends="py-mysqldb"
- mkdir -p "$subpkgdir"
-}
-
-postgresql() {
- pkgdesc="$pkgname postgresql support"
- depends="py-psycopg2"
- mkdir -p "$subpkgdir"
-}
-
-pwclient() {
- pkgdesc="command-line client for patchwork"
- depends="python2"
- install -Dm775 "$pkgdir"/usr/share/webapps/patchwork/patchwork/bin/pwclient \
- "$subpkgdir"/usr/bin/pwclient
-}
-
-sha512sums="95dcfcdf19de0a65a77ab4274de82457c969e3a65705da25cbec742e4d6671e51e629d5366d47ee510a1ac622afde3e2637fa4a013fd576a66808be75a7e84b5 patchwork-2.0.1.tar.gz
-5facc2c2620b2d614011bcdc06bb481fb1481c79333579e5a7fa5b8bc4f97d1651cc8c4632a5e150b62674d64c00345341229319f1edb2016721868e84146826 0001-support-busybox-readlink.patch
-f6d3590b3ac53797e0ae25fe50ab0935608be5ded44665599cbc91e93558895eddc6a7a717153d81fc194b314d7854686577ef5ecf9e0302b7824ce3b3863f7b 0002-remove-uneeded-bashism-from-tools-and-change-path.patch
-28911a25e00a254237f7214fb681e5e984a2eae331e610be62967d5e246958e0f8d3f84861d8fd17c1190c1df72a25f28ddb33843b3679a3864beb00cb4b4961 nginx-uwsgi-patchwork-conf.ini
-862dd2522236a0b18d2a8d06f1ad91ad0fd0936fa502d95e09556641e67d42e1212821bfd7fb98923e4fe8b8a7369ded8c23831fb496b1e2833d9831c1b23725 nginx-patchwork.conf"