aboutsummaryrefslogtreecommitdiffstats
path: root/main/pax-utils
diff options
context:
space:
mode:
authorLeo <thinkabit.ukim@gmail.com>2019-06-08 05:24:43 -0300
committerNatanael Copa <ncopa@alpinelinux.org>2019-06-28 14:45:43 +0000
commitc2bc0a44e12b8015a83e04a9881714deb3526d80 (patch)
tree2a323acc46bc2c2ffcb490d26c43fd9ca327d49f /main/pax-utils
parent8994adf70266295fdc0e0ab98851804a65d20afc (diff)
downloadaports-c2bc0a44e12b8015a83e04a9881714deb3526d80.tar.bz2
aports-c2bc0a44e12b8015a83e04a9881714deb3526d80.tar.xz
main/pax-utils: upgrade to 1.2.4
Diffstat (limited to 'main/pax-utils')
-rw-r--r--main/pax-utils/APKBUILD11
-rw-r--r--main/pax-utils/fix-eitype.patch28
2 files changed, 4 insertions, 35 deletions
diff --git a/main/pax-utils/APKBUILD b/main/pax-utils/APKBUILD
index 8a38a6aaa4..8987decc36 100644
--- a/main/pax-utils/APKBUILD
+++ b/main/pax-utils/APKBUILD
@@ -2,8 +2,8 @@
# Contributor: Sören Tempel <soeren+alpine@soeren-tempel.net>
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=pax-utils
-pkgver=1.2.3
-pkgrel=1
+pkgver=1.2.4
+pkgrel=0
pkgdesc="ELF related utils for ELF 32/64 binaries"
url="https://wiki.gentoo.org/wiki/Hardened/PaX_Utilities"
arch="all"
@@ -12,10 +12,8 @@ depends="scanelf"
makedepends_host="linux-headers libcap-dev"
makedepends="$makedepends_host"
checkdepends="bash python3 py3-elftools"
-source="https://dev.gentoo.org/~slyfox/distfiles/pax-utils-$pkgver.tar.xz
- fix-eitype.patch"
+source="https://dev.gentoo.org/~slyfox/distfiles/pax-utils-$pkgver.tar.xz"
subpackages="$pkgname-doc scanelf:_scanelf"
-builddir="$srcdir"/$pkgname-$pkgver
build() {
cd "$builddir"
@@ -44,5 +42,4 @@ _scanelf() {
mv "$pkgdir"/usr/bin/scanelf "$subpkgdir"/usr/bin/
}
-sha512sums="efcbce49aa7e5cd433f9b3fbc8fa82f6d7b0eb80ec40aafde453d6fe96e3565e066e5020f04d71537d8d4e820147f4203c0df2dd330ebb1358a26def3dd5484c pax-utils-1.2.3.tar.xz
-7150f162a64d9095fab4f73c4a0c531550e2286d6e09a686c62b3a692353b9e33a770ad196f647b5f26b5acafcdef05187dc9d40b40b46d508900dc3e33324a6 fix-eitype.patch"
+sha512sums="03b84054c59e8ce64d2c07276c61245c8e9b3eca2fc430269531e2dafe120009b541ebb6adc4ff54c13a1da63caf0755fb026ba272cf17d04f75e06b893a3e95 pax-utils-1.2.4.tar.xz"
diff --git a/main/pax-utils/fix-eitype.patch b/main/pax-utils/fix-eitype.patch
deleted file mode 100644
index fe54ee8874..0000000000
--- a/main/pax-utils/fix-eitype.patch
+++ /dev/null
@@ -1,28 +0,0 @@
-elf->data is 'signed char' and casting it to 'int' will sign extend.
-Most non-intrusive fix is to just have get_elfeitype() take type as
-'unsigned char' to make implicit cast.
-
-diff -ru pax-utils-1.2.2.orig/paxelf.c pax-utils-1.2.2/paxelf.c
---- pax-utils-1.2.2.orig/paxelf.c 2017-01-24 20:24:53.000000000 +0000
-+++ pax-utils-1.2.2/paxelf.c 2017-09-26 07:01:00.115498082 +0000
-@@ -65,7 +65,7 @@
- QUERY(ELFOSABI_STANDALONE),
- { 0, 0 }
- };
--const char *get_elfeitype(int ei_type, int type)
-+const char *get_elfeitype(int ei_type, unsigned char type)
- {
- switch (ei_type) {
- case EI_CLASS: return find_pairtype(elf_ei_class, type);
-diff -ru pax-utils-1.2.2.orig/paxelf.h pax-utils-1.2.2/paxelf.h
---- pax-utils-1.2.2.orig/paxelf.h 2017-01-24 20:24:53.000000000 +0000
-+++ pax-utils-1.2.2/paxelf.h 2017-09-26 07:00:44.941879820 +0000
-@@ -56,7 +56,7 @@
- extern elfobj *_readelf(const char *filename, int read_only);
- #define readelf(filename) _readelf(filename, 1)
- extern void unreadelf(elfobj *elf);
--extern const char *get_elfeitype(int ei_type, int type);
-+extern const char *get_elfeitype(int ei_type, unsigned char type);
- extern const char *get_elfetype(elfobj *elf);
- extern const char *get_endian(elfobj *elf);
- extern const char *get_elfosabi(elfobj *elf);