aboutsummaryrefslogtreecommitdiffstats
path: root/main/pcre/CVE-2015-5073.patch
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2015-07-07 13:39:52 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2015-08-07 14:47:23 +0000
commit4c80df5bbe4a4fae50293e449e30dd8cb90a298e (patch)
treefdf1baa1f620821052ad0c0f57efa9b260994322 /main/pcre/CVE-2015-5073.patch
parent41732b78666fd19ade073152d29ebf8e01f32a7c (diff)
downloadaports-4c80df5bbe4a4fae50293e449e30dd8cb90a298e.tar.bz2
aports-4c80df5bbe4a4fae50293e449e30dd8cb90a298e.tar.xz
main/pcre: various security fixes
CVE-2015-3210 CVE-2015-3217 CVE-2015-5073 fixes #4289 fixes #4402 (cherry picked from commit 77345a923c72d9e8d0a4202d893239ba43b903a3) Conflicts: main/pcre/APKBUILD
Diffstat (limited to 'main/pcre/CVE-2015-5073.patch')
-rw-r--r--main/pcre/CVE-2015-5073.patch14
1 files changed, 14 insertions, 0 deletions
diff --git a/main/pcre/CVE-2015-5073.patch b/main/pcre/CVE-2015-5073.patch
new file mode 100644
index 0000000000..e6981ecb2c
--- /dev/null
+++ b/main/pcre/CVE-2015-5073.patch
@@ -0,0 +1,14 @@
+Index: pcre_compile.c
+===================================================================
+--- a/pcre_compile.c (revision 1569)
++++ b/pcre_compile.c (revision 1575)
+@@ -9449,7 +9449,7 @@
+ exceptional ones forgo this. We scan the pattern to check that they are fixed
+ length, and set their lengths. */
+
+-if (cd->check_lookbehind)
++if (errorcode == 0 && cd->check_lookbehind)
+ {
+ pcre_uchar *cc = (pcre_uchar *)codestart;
+
+