aboutsummaryrefslogtreecommitdiffstats
path: root/main/pcre2
diff options
context:
space:
mode:
authoralpine-mips-patches <info@mobile-stream.com>2018-12-06 06:36:01 +0000
committerLeonardo Arena <rnalrd@alpinelinux.org>2018-12-17 15:57:33 +0000
commit5e501b0e9403a912350ade906bd3f7396c505d70 (patch)
tree5c46a07e9d192bd2cce856dcfda33c49540452f7 /main/pcre2
parentae7edd23775f55c6d20424294307c13a45a015ae (diff)
downloadaports-5e501b0e9403a912350ade906bd3f7396c505d70.tar.bz2
aports-5e501b0e9403a912350ade906bd3f7396c505d70.tar.xz
main/pcre2: fix JIT options on mips*
1) Disable use of CFC1 (FPU instruction) on all soft-float mips*. 2) Enable MIPS32 ISA (default is MIPS III) on 32-bit mips{el}.
Diffstat (limited to 'main/pcre2')
-rw-r--r--main/pcre2/APKBUILD7
1 files changed, 6 insertions, 1 deletions
diff --git a/main/pcre2/APKBUILD b/main/pcre2/APKBUILD
index fdbd734b4f..e43690696e 100644
--- a/main/pcre2/APKBUILD
+++ b/main/pcre2/APKBUILD
@@ -2,7 +2,7 @@
# Maintainer: Jakub Jirutka <jakub@jirutka.cz>
pkgname=pcre2
pkgver=10.32
-pkgrel=0
+pkgrel=1
pkgdesc="Perl-compatible regular expression library"
url="http://pcre.sourceforge.net/"
arch="all"
@@ -22,6 +22,11 @@ esac
build() {
cd "$builddir"
+ case "$CARCH" in
+ mips64*) export CPPFLAGS="$CPPFLAGS -DSLJIT_IS_FPU_AVAILABLE=0";;
+ mips*) export CPPFLAGS="$CPPFLAGS -DSLJIT_IS_FPU_AVAILABLE=0 -DSLJIT_MIPS_R1=1";;
+ esac
+
# Note: Forced -O3 is recommended (needed?) for Julia.
./configure \
CFLAGS="$CFLAGS -O3" \