aboutsummaryrefslogtreecommitdiffstats
path: root/main/pcre
diff options
context:
space:
mode:
authoralpine-mips-patches <info@mobile-stream.com>2018-12-06 06:36:01 +0000
committerLeonardo Arena <rnalrd@alpinelinux.org>2018-12-17 15:57:33 +0000
commitf785147bab5a08161b1f92a9f8eaf5a588909e7e (patch)
tree4a025739dc948b239afd19d014b96b8bc49f1f33 /main/pcre
parent5e501b0e9403a912350ade906bd3f7396c505d70 (diff)
downloadaports-f785147bab5a08161b1f92a9f8eaf5a588909e7e.tar.bz2
aports-f785147bab5a08161b1f92a9f8eaf5a588909e7e.tar.xz
main/pcre: fix JIT options on mips*
1) Disable use of CFC1 (FPU instruction) on all soft-float mips*. 2) Enable MIPS32 ISA (default is MIPS III) on 32-bit mips{el}.
Diffstat (limited to 'main/pcre')
-rw-r--r--main/pcre/APKBUILD11
1 files changed, 9 insertions, 2 deletions
diff --git a/main/pcre/APKBUILD b/main/pcre/APKBUILD
index 58532b594e..da65eef6bb 100644
--- a/main/pcre/APKBUILD
+++ b/main/pcre/APKBUILD
@@ -2,7 +2,7 @@
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=pcre
pkgver=8.42
-pkgrel=0
+pkgrel=1
pkgdesc="Perl-compatible regular expression library"
url="http://pcre.sourceforge.net"
arch="all"
@@ -25,7 +25,14 @@ builddir="$srcdir/$pkgname-$pkgver"
build() {
cd "$builddir"
- [ "$CARCH" = "s390x" ] && _enable_jit="" || _enable_jit="--enable-jit"
+
+ local _enable_jit="--enable-jit"
+ case "$CARCH" in
+ mips64*) export CPPFLAGS="$CPPFLAGS -DSLJIT_IS_FPU_AVAILABLE=0";;
+ mips*) export CPPFLAGS="$CPPFLAGS -DSLJIT_IS_FPU_AVAILABLE=0 -DSLJIT_MIPS_R1=1";;
+ s390x) _enable_jit="";;
+ esac
+
./configure \
--build=$CBUILD \
--host=$CHOST \