aboutsummaryrefslogtreecommitdiffstats
path: root/main/perl-cache-simple-timedexpiry
diff options
context:
space:
mode:
authorRoberto Oliveira <robertoguimaraes8@gmail.com>2017-11-11 11:01:31 +0000
committerCarlo Landmeter <clandmeter@alpinelinux.org>2017-11-13 09:08:07 +0000
commit58f0c131a333124a60109156cfa23e4e95cf2512 (patch)
treed53f9e4787cb75bed4bb5218744cb50eb9d317b3 /main/perl-cache-simple-timedexpiry
parentffee962c4e9c1002ca21a3d16e545db041327d0f (diff)
downloadaports-58f0c131a333124a60109156cfa23e4e95cf2512.tar.bz2
aports-58f0c131a333124a60109156cfa23e4e95cf2512.tar.xz
main/perl-cache-simple-timedexpiry: add missing make dependency and modernize
Diffstat (limited to 'main/perl-cache-simple-timedexpiry')
-rw-r--r--main/perl-cache-simple-timedexpiry/APKBUILD32
1 files changed, 14 insertions, 18 deletions
diff --git a/main/perl-cache-simple-timedexpiry/APKBUILD b/main/perl-cache-simple-timedexpiry/APKBUILD
index fda723d453..4df6e40af3 100644
--- a/main/perl-cache-simple-timedexpiry/APKBUILD
+++ b/main/perl-cache-simple-timedexpiry/APKBUILD
@@ -1,38 +1,34 @@
# Contributor: Natanael Copa <ncopa@alpinelinux.org>
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=perl-cache-simple-timedexpiry
+_pkgname="Cache-Simple-TimedExpiry"
pkgver=0.27
-pkgrel=0
+pkgrel=1
pkgdesc="Cache::Simple::TimedExpiry perl module"
url="http://search.cpan.org/dist/Cache-Simple-TimedExpiry/"
arch="noarch"
license="GPLv2 or Artistic"
depends="perl"
-makedepends="perl-dev"
-install=""
+makedepends="perl-dev perl-module-install"
subpackages="$pkgname-doc"
source="http://search.cpan.org/CPAN/authors/id/J/JE/JESSE/Cache-Simple-TimedExpiry-$pkgver.tar.gz"
-_builddir="$srcdir"/Cache-Simple-TimedExpiry-$pkgver
-prepare() {
- local i
- cd "$_builddir"
- for i in $source; do
- case $i in
- *.patch) msg $i; patch -p1 -i "$srcdir"/$i || return 1;;
- esac
- done
-}
+builddir="$srcdir/$_pkgname-$pkgver"
build() {
- cd "$_builddir"
- PERL_MM_USE_DEFAULT=1 perl Makefile.PL INSTALLDIRS=vendor || return 1
- make && make test || return 1
+ cd "$builddir"
+ PERL_MM_USE_DEFAULT=1 perl Makefile.PL INSTALLDIRS=vendor
+ make
+}
+
+check() {
+ cd "$builddir"
+ make test
}
package() {
- cd "$_builddir"
- make DESTDIR="$pkgdir" install || return 1
+ cd "$builddir"
+ make DESTDIR="$pkgdir" install
find "$pkgdir" \( -name perllocal.pod -o -name .packlist \) -delete
}