aboutsummaryrefslogtreecommitdiffstats
path: root/main/perl-compress-raw-bzip2
diff options
context:
space:
mode:
authorLeonardo Arena <rnalrd@alpinelinux.org>2018-04-04 07:25:33 +0000
committerLeonardo Arena <rnalrd@alpinelinux.org>2018-04-04 07:25:37 +0000
commit33f86084d6e0bfae777de9b9416055961f495b93 (patch)
treedd05c12fd49c47e9e159df0eb8852fea9424aa58 /main/perl-compress-raw-bzip2
parent9c225e1fef07e6691eb0bce94876bdd7fa84c6a7 (diff)
downloadaports-33f86084d6e0bfae777de9b9416055961f495b93.tar.bz2
aports-33f86084d6e0bfae777de9b9416055961f495b93.tar.xz
main/perl-compress-raw-bzip2: modernize APKBUILD, add check()
Diffstat (limited to 'main/perl-compress-raw-bzip2')
-rw-r--r--main/perl-compress-raw-bzip2/APKBUILD34
1 files changed, 20 insertions, 14 deletions
diff --git a/main/perl-compress-raw-bzip2/APKBUILD b/main/perl-compress-raw-bzip2/APKBUILD
index da36d05b11..880030b8e1 100644
--- a/main/perl-compress-raw-bzip2/APKBUILD
+++ b/main/perl-compress-raw-bzip2/APKBUILD
@@ -1,36 +1,42 @@
# Contributor: Leonardo Arena <rnalrd@alpinelinux.org>
# Maintainer: Leonardo Arena <rnalrd@alpinelinux.org>
pkgname=perl-compress-raw-bzip2
-_realname=Compress-Raw-Bzip2
+_pkgname=Compress-Raw-Bzip2
pkgver=2.080
-pkgrel=0
+pkgrel=1
pkgdesc="Perl low-level interface to bzip2 compression library"
url="http://search.cpan.org/~pmqs/Compress-Raw-Bzip2-2.024/"
arch="all"
license="GPL PerlArtistic"
depends="perl"
makedepends="perl-dev"
-install=
-subpackages=""
-source="http://search.cpan.org/CPAN/authors/id/P/PM/PMQS/${_realname}-${pkgver}.tar.gz"
+source="http://search.cpan.org/CPAN/authors/id/P/PM/PMQS/${_pkgname}-${pkgver}.tar.gz"
+builddir="$srcdir/$_pkgname-$pkgver"
-_builddir="$srcdir/$_realname-$pkgver"
+prepare() {
+ default_prepare
+ PERL_MM_USE_DEFAULT=1 perl Makefile.PL INSTALLDIRS=vendor
+}
build() {
- cd $_builddir
- PERL_MM_USE_DEFAULT=1 perl Makefile.PL INSTALLDIRS=vendor || return 1
- #PERL_MM_USE_DEFAULT=1 perl Makefile.PL || return 1
- make || return 1
+ cd $builddir
+ export CFLAGS=$(perl -MConfig -E 'say $Config{ccflags}')
+ make
+}
+
+check() {
+ cd "$builddir"
+ export CFLAGS=$(perl -MConfig -E 'say $Config{ccflags}')
+ make test
}
package() {
- cd $_builddir
+ cd $builddir
make DESTDIR="$pkgdir" install
- # creates file collision among perl modules
- find "$pkgdir" -name perllocal.pod -delete
+ find "$pkgdir" \( -name perllocal.pod -o -name .packlist \) -delete
# remove man pages already provided by perl-doc
- rm -rf "$pkgdir"/usr/share/man || return 1
+ rm -rf "$pkgdir"/usr/share/man
}
sha512sums="3774dd1ed05833024194f0ebcecda38e03280050767dad4682713a9f844923a2f7440319771361cf6fd78c1b94a426c6abca0ff833111ee02de85777da1e39ce Compress-Raw-Bzip2-2.080.tar.gz"