aboutsummaryrefslogtreecommitdiffstats
path: root/main/perl-cps
diff options
context:
space:
mode:
authorLeo <thinkabit.ukim@gmail.com>2019-05-27 20:41:16 -0300
committerTimo Teräs <timo.teras@iki.fi>2019-05-28 10:02:31 +0300
commitca1f2455b3830bac71a32f2fc5e95947d3684ea5 (patch)
tree1d08b2dece6ae8256f21aabebe155708edc907c9 /main/perl-cps
parent167e1c02824af221b9731513ddfb644f860f34dc (diff)
downloadaports-ca1f2455b3830bac71a32f2fc5e95947d3684ea5.tar.bz2
aports-ca1f2455b3830bac71a32f2fc5e95947d3684ea5.tar.xz
main/perl-cps: upgrade to 0.19
Diffstat (limited to 'main/perl-cps')
-rw-r--r--main/perl-cps/APKBUILD37
1 files changed, 21 insertions, 16 deletions
diff --git a/main/perl-cps/APKBUILD b/main/perl-cps/APKBUILD
index 76329bc7ff..30737d81e9 100644
--- a/main/perl-cps/APKBUILD
+++ b/main/perl-cps/APKBUILD
@@ -3,39 +3,44 @@
# Maintainer: Kiyoshi Aman <kiyoshi.aman@gmail.com>
pkgname=perl-cps
_pkgreal=CPS
-pkgver=0.18
+pkgver=0.19
pkgrel=0
pkgdesc="manage flow of control in Continuation-Passing Style"
url="http://search.cpan.org/dist/CPS/"
arch="noarch"
-license="GPL PerlArtistic"
-cpandepends="perl-future"
-cpanmakedepends="perl-test-identity perl-test-refcount perl-test-fatal "
+license="GPL-1.0-or-later OR Artistic-1.0-Perl"
+cpandepends="perl-future perl-sub-name"
+cpanmakedepends="perl-test-identity perl-test-refcount perl-test-fatal"
depends="$cpandepends"
-makedepends="perl-dev perl-test-fatal perl-test-identity perl-test-refcount
- $cpanmakedepends perl-module-build"
+makedepends="$cpanmakedepends perl-dev perl-module-build"
subpackages="$pkgname-doc"
source="http://search.cpan.org/CPAN/authors/id/P/PE/PEVANS/$_pkgreal-$pkgver.tar.gz"
-_builddir="$srcdir/$_pkgreal-$pkgver"
+builddir="$srcdir/$_pkgreal-$pkgver"
prepare() {
- cd "$_builddir"
- perl Build.PL installdirs=vendor || return 1
+ default_prepare
+
+ cd "$builddir"
+ export CFLAGS=$(perl -MConfig -E 'say $Config{ccflags}')
+ perl Build.PL installdirs=vendor
}
build() {
- cd "$_builddir"
- export CFLAGS=`perl -MConfig -E 'say $Config{ccflags}'`
- ./Build && ./Build test
+ cd "$builddir"
+ export CFLAGS=$(perl -MConfig -E 'say $Config{ccflags}')
+ ./Build
+}
+
+check() {
+ cd "$builddir"
+ ./Build test
}
package() {
cd "$_builddir"
- ./Build install destdir="$pkgdir" || return 1
+ ./Build install destdir="$pkgdir"
find "$pkgdir" \( -name perllocal.pod -o -name .packlist \) -delete
}
-md5sums="c011f5e8d5c0f8343e93f3edf0083854 CPS-0.18.tar.gz"
-sha256sums="2cd41f7d4dc091015fc7a4a4d3a6b58e2670d36c7ac47c6dec0538c7e732bfe6 CPS-0.18.tar.gz"
-sha512sums="737e182b803b4d3b45e1b82410aec171815e2dc98cde507a172ccbf6667b811397c912b02d92c9da9266dc5face69e4c6c772c7dcb63b39b7c68f782c070fa68 CPS-0.18.tar.gz"
+sha512sums="58479ba56554c6028db34fccc3942eba9e6cd7bfd5a1ee90b540db6d3ed3ef3b61aee354829cde386bc2beef134ee057dd96a5fd1e074d1389f46c8c54a312b0 CPS-0.19.tar.gz"