aboutsummaryrefslogtreecommitdiffstats
path: root/main/perl-dbd-sqlite/perl-DBD-SQLite-bz543982.patch
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2013-10-17 06:06:37 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2013-10-17 06:36:04 +0000
commit86345a32f811c11e79e43c8b76cf00ffa3cb3f94 (patch)
tree6de7e57cd3fb4c29b8f09e0e8a4397f012baae2e /main/perl-dbd-sqlite/perl-DBD-SQLite-bz543982.patch
parent8179df58fdc6143843c492f008c9bd047254ea51 (diff)
downloadaports-86345a32f811c11e79e43c8b76cf00ffa3cb3f94.tar.bz2
aports-86345a32f811c11e79e43c8b76cf00ffa3cb3f94.tar.xz
main/perl-dbd-sqlite: split out -dev subpackage and use system sqlite
ref #2277
Diffstat (limited to 'main/perl-dbd-sqlite/perl-DBD-SQLite-bz543982.patch')
-rw-r--r--main/perl-dbd-sqlite/perl-DBD-SQLite-bz543982.patch12
1 files changed, 12 insertions, 0 deletions
diff --git a/main/perl-dbd-sqlite/perl-DBD-SQLite-bz543982.patch b/main/perl-dbd-sqlite/perl-DBD-SQLite-bz543982.patch
new file mode 100644
index 0000000000..6057ce097a
--- /dev/null
+++ b/main/perl-dbd-sqlite/perl-DBD-SQLite-bz543982.patch
@@ -0,0 +1,12 @@
+diff -up DBD-SQLite-1.27/Makefile.PL.old DBD-SQLite-1.27/Makefile.PL
+--- DBD-SQLite-1.27/Makefile.PL.old 2009-11-23 12:08:05.000000000 +0100
++++ DBD-SQLite-1.27/Makefile.PL 2010-01-11 15:40:56.456399143 +0100
+@@ -123,7 +123,7 @@ if ( $@ or DBI->VERSION < $DBI_required
+ # a system sqlite is also sophisticated enough to have a patching system
+ # that can change the if ( 0 ) to if ( 1 )
+ my ($sqlite_local, $sqlite_base, $sqlite_lib, $sqlite_inc);
+-if ( 0 ) {
++if ( 1 ) {
+ require File::Spec;
+ if ( $sqlite_base = (grep(/SQLITE_LOCATION=.*/, @ARGV))[0] ) {
+ $sqlite_base =~ /=(.*)/;