aboutsummaryrefslogtreecommitdiffstats
path: root/main/perl-file-rsync/perl-file-rsync-parallell-build-fix.patch
diff options
context:
space:
mode:
authorLeonardo Arena <rnalrd@gmail.com>2010-03-02 10:14:13 +0000
committerLeonardo Arena <rnalrd@gmail.com>2010-03-02 10:14:13 +0000
commit0b1f1a950efe75a977d42cc05488816da0cce3c4 (patch)
tree42cb2cb36f076d86ce7347811f1e0b6057f7696d /main/perl-file-rsync/perl-file-rsync-parallell-build-fix.patch
parent9a0c738a493841c30e537851f238c22b0826a2d6 (diff)
downloadaports-0b1f1a950efe75a977d42cc05488816da0cce3c4.tar.bz2
aports-0b1f1a950efe75a977d42cc05488816da0cce3c4.tar.xz
main/perl-file-rsync: parallel build fix
Diffstat (limited to 'main/perl-file-rsync/perl-file-rsync-parallell-build-fix.patch')
-rw-r--r--main/perl-file-rsync/perl-file-rsync-parallell-build-fix.patch20
1 files changed, 20 insertions, 0 deletions
diff --git a/main/perl-file-rsync/perl-file-rsync-parallell-build-fix.patch b/main/perl-file-rsync/perl-file-rsync-parallell-build-fix.patch
new file mode 100644
index 0000000000..d9316f3d19
--- /dev/null
+++ b/main/perl-file-rsync/perl-file-rsync-parallell-build-fix.patch
@@ -0,0 +1,20 @@
+diff --git a/FileList/Makefile.PL b/FileList/Makefile.PL
+index 2061b0a..3ab345f 100644
+--- a/FileList/Makefile.PL
++++ b/FileList/Makefile.PL
+@@ -16,7 +16,14 @@ WriteMakefile(
+ snprintf$(OBJ_EXT)
+ wildmatch$(OBJ_EXT)
+ ],
+- 'depend' => { 'FileList.o' => 'config.h' },
++ 'depend' => { 'FileList$(OBJ_EXT)' => 'config.h',
++ 'exclude$(OBJ_EXT)' => 'config.h',
++ 'flist$(OBJ_EXT)' => 'config.h',
++ 'hlink$(OBJ_EXT)' => 'config.h',
++ 'pool_alloc$(OBJ_EXT)' => 'config.h',
++ 'snprintf$(OBJ_EXT)' => 'config.h',
++ 'wildmatch$(OBJ_EXT)' => 'config.h',
++ },
+ 'clean' => {FILES => "configure.in config.log config.status config.h conftest* confdefs*"},
+ );
+