aboutsummaryrefslogtreecommitdiffstats
path: root/main/perl-module-implementation
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2019-05-10 16:56:46 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2019-05-11 07:12:58 +0000
commit2cb0c5c2e4eb1ca809d49441dfe12e7baff59d0b (patch)
treeeb63300a9311007e65e96d0111db3eaa1fc73bff /main/perl-module-implementation
parentb76feea3f452363a7e33f1d71a287ee637281381 (diff)
downloadaports-2cb0c5c2e4eb1ca809d49441dfe12e7baff59d0b.tar.bz2
aports-2cb0c5c2e4eb1ca809d49441dfe12e7baff59d0b.tar.xz
main/perl-module-implementation: merge with the version from community
Diffstat (limited to 'main/perl-module-implementation')
-rw-r--r--main/perl-module-implementation/APKBUILD31
1 files changed, 18 insertions, 13 deletions
diff --git a/main/perl-module-implementation/APKBUILD b/main/perl-module-implementation/APKBUILD
index 3099f634b0..21ea82a255 100644
--- a/main/perl-module-implementation/APKBUILD
+++ b/main/perl-module-implementation/APKBUILD
@@ -1,41 +1,46 @@
# Automatically generated by apkbuild-cpan, template 1
-# Contributor:
-# Maintainer:
+# Contributor: Francesco Colista <fcolista@alpinelinux.org>
+# Maintainer: Francesco Colista <fcolista@alpinelinux.org>
pkgname=perl-module-implementation
_pkgreal=Module-Implementation
pkgver=0.09
-pkgrel=0
+pkgrel=1
pkgdesc="Loads one of several alternate underlying implementations for a module"
url="http://search.cpan.org/dist/Module-Implementation/"
arch="noarch"
license="Artistic-2.0"
-cpandepends="perl-try-tiny perl-module-runtime"
-cpanmakedepends=" perl-test-fatal perl-test-requires "
+cpandepends="perl-module-runtime perl-try-tiny perl-test-taint"
+cpanmakedepends="perl-test-fatal perl-test-requires "
depends="$cpandepends"
makedepends="perl-dev $cpanmakedepends"
subpackages="$pkgname-doc"
source="http://search.cpan.org/CPAN/authors/id/D/DR/DROLSKY/$_pkgreal-$pkgver.tar.gz"
-_builddir="$srcdir/$_pkgreal-$pkgver"
+builddir="$srcdir/$_pkgreal-$pkgver"
prepare() {
- cd "$_builddir"
+ default_prepare
+
+ cd "$builddir"
export CFLAGS=`perl -MConfig -E 'say $Config{ccflags}'`
PERL_MM_USE_DEFAULT=1 perl Makefile.PL INSTALLDIRS=vendor
}
build() {
- cd "$_builddir"
+ cd "$builddir"
export CFLAGS=`perl -MConfig -E 'say $Config{ccflags}'`
- make && make test
+ make
+}
+
+check() {
+ cd "$builddir"
+ make test
}
package() {
- cd "$_builddir"
- make DESTDIR="$pkgdir" install || return 1
+ cd "$builddir"
+ make DESTDIR="$pkgdir" install
find "$pkgdir" \( -name perllocal.pod -o -name .packlist \) -delete
}
-md5sums="52e3fe0ca6b1eff0488d59b7aacc0667 Module-Implementation-0.09.tar.gz"
-sha256sums="c15f1a12f0c2130c9efff3c2e1afe5887b08ccd033bd132186d1e7d5087fd66d Module-Implementation-0.09.tar.gz"
sha512sums="049f967ba1bd8a3914968b34006030ae318d99ac629a0f34736f1c2b5392490c30aa0914e777eaefda7f0f58755d2d3363a266b90db59b53fe145ef68e1d953c Module-Implementation-0.09.tar.gz"