aboutsummaryrefslogtreecommitdiffstats
path: root/main/perl-module-runtime
diff options
context:
space:
mode:
authorRoberto Oliveira <robertoguimaraes8@gmail.com>2018-07-15 18:43:45 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2018-07-16 11:01:56 +0000
commitf975a0c7c69c599f85ca6a0ba6ff071a349b24e8 (patch)
treeebe2e03756abdbff1eb68e6a5cce1805f59b2140 /main/perl-module-runtime
parent25bdffea6be951dfb52239c5d4af8232b7ae3a01 (diff)
downloadaports-f975a0c7c69c599f85ca6a0ba6ff071a349b24e8.tar.bz2
aports-f975a0c7c69c599f85ca6a0ba6ff071a349b24e8.tar.xz
main/perl-module-runtime: upgrade to 0.016 and modernize
Diffstat (limited to 'main/perl-module-runtime')
-rw-r--r--main/perl-module-runtime/APKBUILD34
1 files changed, 18 insertions, 16 deletions
diff --git a/main/perl-module-runtime/APKBUILD b/main/perl-module-runtime/APKBUILD
index a0f3709e49..9fd936758c 100644
--- a/main/perl-module-runtime/APKBUILD
+++ b/main/perl-module-runtime/APKBUILD
@@ -3,38 +3,40 @@
# Maintainer: Francesco Colista <francesco.colista@gmail.com>
pkgname=perl-module-runtime
_pkgreal=Module-Runtime
-pkgver=0.014
-pkgrel=1
-pkgdesc="runtime module handling"
+pkgver=0.016
+pkgrel=0
+pkgdesc="Runtime module handling"
url="http://search.cpan.org/dist/Module-Runtime/"
arch="noarch"
license="GPL PerlArtistic"
cpandepends="perl-params-classify"
-cpanmakedepends=" "
depends="$cpandepends perl-module-build"
-makedepends="perl-dev $cpanmakedepends"
+makedepends="perl-dev"
subpackages="$pkgname-doc"
source="http://search.cpan.org/CPAN/authors/id/Z/ZE/ZEFRAM/$_pkgreal-$pkgver.tar.gz"
-_builddir="$srcdir/$_pkgreal-$pkgver"
+builddir="$srcdir/$_pkgreal-$pkgver"
prepare() {
- cd "$_builddir"
- perl Build.PL installdirs=vendor || return 1
+ cd "$builddir"
+ perl Build.PL installdirs=vendor
}
build() {
- cd "$_builddir"
- export CFLAGS=`perl -MConfig -E 'say $Config{ccflags}'`
- ./Build && ./Build test
+ cd "$builddir"
+ export CFLAGS=`perl -MConfig -E 'say $Config{ccflags}'`
+ ./Build
+}
+
+check() {
+ cd "$builddir"
+ ./Build test
}
package() {
- cd "$_builddir"
- ./Build install destdir="$pkgdir" || return 1
+ cd "$builddir"
+ ./Build install destdir="$pkgdir"
find "$pkgdir" \( -name perllocal.pod -o -name .packlist \) -delete
}
-md5sums="a6597bc25536a30476f0d75b64d35734 Module-Runtime-0.014.tar.gz"
-sha256sums="4c44fe0ea255a9fd00741ee545063f6692d2a28e7ef2fbaad1b24a92803362a4 Module-Runtime-0.014.tar.gz"
-sha512sums="5431d9aeb092bb357bafed4e4cf216e9eda4bbbdd0c27547a1729adbb2f6f5a114ac25580a814f2d07844d6b742b9df3ca8d5972668bcacab2f791d617c1d32b Module-Runtime-0.014.tar.gz"
+sha512sums="64a362ee897646173dbbdd8794f863d93379d45d7ac20d3ae890d77b4ec3f5e36aaff66c41b4a6a33b28bf492216283528755550ab09e466ceafb4f0cfbaeb9e Module-Runtime-0.016.tar.gz"