aboutsummaryrefslogtreecommitdiffstats
path: root/main/perl-module-runtime
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2019-05-10 17:37:02 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2019-05-11 07:12:58 +0000
commit1e911572d9067c970873c9e4ccc063daabbb6468 (patch)
tree39b04be764a84d9ce203bb4d020a7bc12d86db51 /main/perl-module-runtime
parent2cb0c5c2e4eb1ca809d49441dfe12e7baff59d0b (diff)
downloadaports-1e911572d9067c970873c9e4ccc063daabbb6468.tar.bz2
aports-1e911572d9067c970873c9e4ccc063daabbb6468.tar.xz
main/perl-module-runtime: merge with the community/perl-module-runtime
we dont need have same package in both main and community
Diffstat (limited to 'main/perl-module-runtime')
-rw-r--r--main/perl-module-runtime/APKBUILD29
1 files changed, 15 insertions, 14 deletions
diff --git a/main/perl-module-runtime/APKBUILD b/main/perl-module-runtime/APKBUILD
index 8d60a21352..465d920b1f 100644
--- a/main/perl-module-runtime/APKBUILD
+++ b/main/perl-module-runtime/APKBUILD
@@ -1,25 +1,31 @@
# Automatically generated by apkbuild-cpan, template 1
-# Contributor: Francesco Colista <francesco.colista@gmail.com>
-# Maintainer: Francesco Colista <francesco.colista@gmail.com>
+# Contributor: Francesco Colista <fcolista@alpinelinux.org>
+# Maintainer: Francesco Colista <fcolista@alpinelinux.org>
pkgname=perl-module-runtime
_pkgreal=Module-Runtime
pkgver=0.016
-pkgrel=1
-pkgdesc="Runtime module handling"
+pkgrel=2
+pkgdesc="runtime module handling"
url="http://search.cpan.org/dist/Module-Runtime/"
arch="noarch"
license="GPL PerlArtistic"
-cpandepends="perl-params-classify"
-depends="$cpandepends perl-module-build"
-makedepends="perl-dev"
-checkdepends="perl-test-pod perl-test-pod-coverage"
+cpandepends=""
+cpanmakedepends="perl-test-pod perl-test-pod-coverage perl-module-build"
+depends="$cpandepends"
+makedepends="perl-dev $cpanmakedepends"
subpackages="$pkgname-doc"
source="http://search.cpan.org/CPAN/authors/id/Z/ZE/ZEFRAM/$_pkgreal-$pkgver.tar.gz"
builddir="$srcdir/$_pkgreal-$pkgver"
+check() {
+ cd "$builddir"
+ ./Build test
+}
+
prepare() {
cd "$builddir"
+ export CFLAGS=`perl -MConfig -E 'say $Config{ccflags}'`
perl Build.PL installdirs=vendor
}
@@ -29,14 +35,9 @@ build() {
./Build
}
-check() {
- cd "$builddir"
- ./Build test
-}
-
package() {
cd "$builddir"
- ./Build install destdir="$pkgdir"
+ ./Build install destdir="$pkgdir" || return 1
find "$pkgdir" \( -name perllocal.pod -o -name .packlist \) -delete
}