aboutsummaryrefslogtreecommitdiffstats
path: root/main/perl-path-tiny
diff options
context:
space:
mode:
authorRoberto Oliveira <robertoguimaraes8@gmail.com>2017-11-16 16:33:40 +0000
committerFrancesco Colista <fcolista@alpinelinux.org>2017-11-16 18:07:31 +0000
commit0d8010c63fc8ae1459d0c2524186485683b368e8 (patch)
treeecee3e4da226cfb32115b3909fb144c0d9c33017 /main/perl-path-tiny
parent396bd8af65b9a8328c654e8a859e15e0d6d7d4a4 (diff)
downloadaports-0d8010c63fc8ae1459d0c2524186485683b368e8.tar.bz2
aports-0d8010c63fc8ae1459d0c2524186485683b368e8.tar.xz
community/perl-path-tiny: move to main
It is required by perl-test-file-sharedir package
Diffstat (limited to 'main/perl-path-tiny')
-rw-r--r--main/perl-path-tiny/APKBUILD45
1 files changed, 45 insertions, 0 deletions
diff --git a/main/perl-path-tiny/APKBUILD b/main/perl-path-tiny/APKBUILD
new file mode 100644
index 0000000000..ded5e18289
--- /dev/null
+++ b/main/perl-path-tiny/APKBUILD
@@ -0,0 +1,45 @@
+# Automatically generated by apkbuild-cpan, template 1
+# Contributor: Francesco Colista <fcolista@alpinelinux.org>
+# Maintainer: Francesco Colista <fcolista@alpinelinux.org>
+pkgname=perl-path-tiny
+_pkgreal=Path-Tiny
+pkgver=0.104
+pkgrel=1
+pkgdesc="File path utility"
+url="http://search.cpan.org/dist/Path-Tiny/"
+arch="noarch"
+license="apache_2_0"
+cpandepends=""
+cpanmakedepends="perl-test-mockrandom perl-test-failwarnings"
+depends="$cpandepends"
+makedepends="perl-dev $cpanmakedepends"
+subpackages="$pkgname-doc"
+source="http://search.cpan.org/CPAN/authors/id/D/DA/DAGOLDEN/$_pkgreal-$pkgver.tar.gz"
+builddir="$srcdir/$_pkgreal-$pkgver"
+
+prepare() {
+ default_prepare
+
+ cd "$builddir"
+ export CFLAGS=$(perl -MConfig -E 'say $Config{ccflags}')
+ PERL_MM_USE_DEFAULT=1 perl Makefile.PL INSTALLDIRS=vendor
+}
+
+build() {
+ cd "$builddir"
+ export CFLAGS=$(perl -MConfig -E 'say $Config{ccflags}')
+ make
+}
+
+check() {
+ cd "$builddir"
+ make test
+}
+
+package() {
+ cd "$builddir"
+ make DESTDIR="$pkgdir" install || return 1
+ find "$pkgdir" \( -name perllocal.pod -o -name .packlist \) -delete
+}
+
+sha512sums="6574e48645ebb4f61d45c1365e8b63cfaac6423394ba08363cfd62d3d98d163bd333d997bf5f7fd0e37ff94fcb3a3e19871eb7499b295399f048fd6a4bd3c78c Path-Tiny-0.104.tar.gz"