aboutsummaryrefslogtreecommitdiffstats
path: root/main/perl-sub-identify
diff options
context:
space:
mode:
authorFrancesco Colista <fcolista@alpinelinux.org>2017-04-03 06:38:24 +0000
committerFrancesco Colista <fcolista@alpinelinux.org>2017-04-03 07:25:27 +0000
commita5f45477f122edf5af9cbf3dcd13cdc37e021f40 (patch)
tree746dc0d6d4574c8ffb45449f24a0d8a6e70c21d3 /main/perl-sub-identify
parentedf6ae9849266e283839c8ee135f8ef8fa4ce2ee (diff)
downloadaports-a5f45477f122edf5af9cbf3dcd13cdc37e021f40.tar.bz2
aports-a5f45477f122edf5af9cbf3dcd13cdc37e021f40.tar.xz
main/perl-sub-identify: upgrade to 0.13, modernize APKBUILD
Diffstat (limited to 'main/perl-sub-identify')
-rw-r--r--main/perl-sub-identify/APKBUILD24
1 files changed, 13 insertions, 11 deletions
diff --git a/main/perl-sub-identify/APKBUILD b/main/perl-sub-identify/APKBUILD
index 53ab49ffe1..af087df214 100644
--- a/main/perl-sub-identify/APKBUILD
+++ b/main/perl-sub-identify/APKBUILD
@@ -3,8 +3,8 @@
# Maintainer: Francesco Colista <fcolista@alpinelinux.org>
pkgname=perl-sub-identify
_pkgreal=Sub-Identify
-pkgver=0.12
-pkgrel=1
+pkgver=0.13
+pkgrel=0
pkgdesc="Retrieve names of code references"
url="http://search.cpan.org/dist/Sub-Identify/"
arch="all"
@@ -16,26 +16,28 @@ makedepends="perl-dev $cpanmakedepends"
subpackages="$pkgname-doc"
source="http://search.cpan.org/CPAN/authors/id/R/RG/RGARCIA/$_pkgreal-$pkgver.tar.gz"
-_builddir="$srcdir/$_pkgreal-$pkgver"
+builddir="$srcdir/$_pkgreal-$pkgver"
+check() {
+ cd "$builddir"
+ make test
+}
prepare() {
- cd "$_builddir"
+ cd "$builddir"
export CFLAGS=`perl -MConfig -E 'say $Config{ccflags}'`
PERL_MM_USE_DEFAULT=1 perl Makefile.PL INSTALLDIRS=vendor
}
build() {
- cd "$_builddir"
+ cd "$builddir"
export CFLAGS=`perl -MConfig -E 'say $Config{ccflags}'`
- make && make test
+ make
}
package() {
- cd "$_builddir"
- make DESTDIR="$pkgdir" install || return 1
+ cd "$builddir"
+ make DESTDIR="$pkgdir" install
find "$pkgdir" \( -name perllocal.pod -o -name .packlist \) -delete
}
-md5sums="e9223e830bfdfbd6f40675e3bec76688 Sub-Identify-0.12.tar.gz"
-sha256sums="83bb785a66113b4a966db0a4186fd1dd07987acdacb4502b1e1558f817dde825 Sub-Identify-0.12.tar.gz"
-sha512sums="47b89866ecdd2b7caaba4a440bd695ab42d92c56721bc43a7fc114c2870a5e536ed17e05eec4ac62525c9fad26e24c299aadc852fd15d58bd626dfdb6478e40f Sub-Identify-0.12.tar.gz"
+sha512sums="16655ea9324202e578ab44139816d61ef961d61c97e2393c19337692670a3f7a27d8dacb7db7b1130ed762f3b6dfc98fe39fe379b546b32576c19bdfa7df70a0 Sub-Identify-0.13.tar.gz"