aboutsummaryrefslogtreecommitdiffstats
path: root/main/perl-test-mockmodule
diff options
context:
space:
mode:
authorLeo <thinkabit.ukim@gmail.com>2019-08-25 13:12:55 -0300
committerNatanael Copa <ncopa@alpinelinux.org>2019-08-26 09:25:30 +0000
commit4dd994fbd8836b9c5d48221a7fe4a2a4b3a64707 (patch)
treecc130201c86d601cfa2a89f9c44745e69e938eec /main/perl-test-mockmodule
parent2878450e964714437c7bde27f3529d8df5b8e053 (diff)
downloadaports-4dd994fbd8836b9c5d48221a7fe4a2a4b3a64707.tar.bz2
aports-4dd994fbd8836b9c5d48221a7fe4a2a4b3a64707.tar.xz
main/perl-test-mockmodule: upgrade to 0.170.0
Diffstat (limited to 'main/perl-test-mockmodule')
-rw-r--r--main/perl-test-mockmodule/APKBUILD16
1 files changed, 8 insertions, 8 deletions
diff --git a/main/perl-test-mockmodule/APKBUILD b/main/perl-test-mockmodule/APKBUILD
index 9e466cd422..f17553061d 100644
--- a/main/perl-test-mockmodule/APKBUILD
+++ b/main/perl-test-mockmodule/APKBUILD
@@ -1,29 +1,29 @@
# Maintainer: Leonardo Arena <rnalrd@alpinelinux.org>
pkgname=perl-test-mockmodule
_pkgname=Test-MockModule
-pkgver=0.15
+pkgver=0.170.0
pkgrel=0
pkgdesc="Override subroutines in a module for unit testing"
url="https://metacpan.org/release/Test-MockModule"
arch="noarch"
-license="GPL-1.0-or-later PerlArtistic"
+license="GPL-1.0-or-later OR Artistic-1.0-Perl"
depends="perl"
makedepends="perl-dev perl-module-build perl-test-warnings perl-super
perl-sub-identify"
subpackages="$pkgname-doc"
-source="https://cpan.metacpan.org/authors/id/G/GF/GFRANKS/Test-MockModule-$pkgver.tar.gz"
-builddir="$srcdir/$_pkgname-$pkgver"
+source="https://cpan.metacpan.org/authors/id/G/GF/GFRANKS/Test-MockModule-v$pkgver.tar.gz"
+builddir="$srcdir/$_pkgname-v$pkgver"
prepare() {
default_prepare
cd "$builddir"
- export CFLAGS=`perl -MConfig -E 'say $Config{ccflags}'`
+ export CFLAGS=$(perl -MConfig -E 'say $Config{ccflags}')
PERL_MM_USE_DEFAULT=1 perl Build.PL installdirs=vendor prefix=/usr
}
build() {
cd "$builddir"
- export CFLAGS=`perl -MConfig -E 'say $Config{ccflags}'`
+ export CFLAGS=$(perl -MConfig -E 'say $Config{ccflags}')
PERL_MM_USE_DEFAULT=1 perl Build
}
@@ -34,8 +34,8 @@ check() {
package() {
cd "$builddir"
- PERL_MM_USE_DEFAULT=1 perl Build install destdir="$pkgdir"
+ PERL_MM_USE_DEFAULT=1 perl Build install destdir="$pkgdir"
find "$pkgdir" \( -name perllocal.pod -o -name .packlist \) -delete
}
-sha512sums="20f64f9984010ee0b3c26532a8835156b7cc8837e436c0785a2d3b7959cb01f07584b816d754da9f9205e457fe5d4a8316d984bf215d242000704fe0c52284a7 Test-MockModule-0.15.tar.gz"
+sha512sums="e62f79eb5c737838a0276bb1de5301e3f2eceef4f9b80fde0678e16490419f2d02afd24ab292e938b923a7d214e3aa60e73baf0d17da7047ca37064111c3ff79 Test-MockModule-v0.170.0.tar.gz"