aboutsummaryrefslogtreecommitdiffstats
path: root/main/perl-test-without-module
diff options
context:
space:
mode:
authorLeonardo Arena <rnalrd@alpinelinux.org>2016-11-01 10:41:33 +0000
committerLeonardo Arena <rnalrd@alpinelinux.org>2016-11-01 10:41:33 +0000
commita03719abb0402c7b49e067acebb3f574a67696e5 (patch)
tree915f3e9d6546a9eb64d299fdce7dfd48a48a873f /main/perl-test-without-module
parent2f90419c5292571dcfc3201393d096eda23bc178 (diff)
downloadaports-a03719abb0402c7b49e067acebb3f574a67696e5.tar.bz2
aports-a03719abb0402c7b49e067acebb3f574a67696e5.tar.xz
main/perl-test-without-module: new aport
Diffstat (limited to 'main/perl-test-without-module')
-rw-r--r--main/perl-test-without-module/APKBUILD41
1 files changed, 41 insertions, 0 deletions
diff --git a/main/perl-test-without-module/APKBUILD b/main/perl-test-without-module/APKBUILD
new file mode 100644
index 0000000000..fe93f15735
--- /dev/null
+++ b/main/perl-test-without-module/APKBUILD
@@ -0,0 +1,41 @@
+# Maintainer: Leonardo Arena <rnalrd@alpinelinux.org>
+pkgname=perl-test-without-module
+_pkgreal="Test-Without-Module"
+pkgver=0.18
+pkgrel=0
+pkgdesc="Test::Without::Module perl module"
+url="http://search.cpan.org"
+arch="noarch"
+license="GPL or Artistic"
+depends=""
+makedepends="perl-dev"
+install=""
+subpackages="$pkgname-doc"
+source="http://search.cpan.org/CPAN/authors/id/C/CO/CORION/Test-Without-Module-$pkgver.tar.gz"
+
+_builddir="$srcdir"/$_pkgreal-$pkgver
+prepare() {
+ local i
+ cd "$_builddir"
+ for i in $source; do
+ case $i in
+ *.patch) msg $i; patch -p1 -i "$srcdir"/$i || return 1;;
+ esac
+ done
+}
+
+build() {
+ cd "$_builddir"
+ PERL_MM_USE_DEFAULT=1 perl Makefile.PL INSTALLDIRS=vendor || return 1
+ make && make test || return 1
+}
+
+package() {
+ cd "$_builddir"
+ make DESTDIR="$pkgdir" install || return 1
+ find "$pkgdir" \( -name perllocal.pod -o -name .packlist \) -delete
+}
+
+md5sums="cd19ad26024e89fdfefb0ae0334ee500 Test-Without-Module-0.18.tar.gz"
+sha256sums="e2c3360b171d7db518ac39a0e1dcb285c784ea393c11708914a0655d66138c7f Test-Without-Module-0.18.tar.gz"
+sha512sums="005ad54ac77283cf3155befe77fdb887dbc2ebc9c154472a23982636bbe7728154f56fdf1990b833639cd687b38e4d62250edd6dd93d37408e971bb4bd49c4c2 Test-Without-Module-0.18.tar.gz"