aboutsummaryrefslogtreecommitdiffstats
path: root/main/perl-xml-simple/APKBUILD
diff options
context:
space:
mode:
authorA. Wilcox <AWilcox@Wilcox-Tech.com>2018-02-10 13:23:28 -0600
committerWilliam Pitcock <nenolod@dereferenced.org>2018-02-12 14:44:48 +0000
commit1502dd329a42c9f50dd468a5c13b8222f9d0697c (patch)
tree86c04801cc36d12794c915c165b06d8c8c5d9992 /main/perl-xml-simple/APKBUILD
parent804f3c73729ff3fa5c8cf2c8959855c5dce09845 (diff)
downloadaports-1502dd329a42c9f50dd468a5c13b8222f9d0697c.tar.bz2
aports-1502dd329a42c9f50dd468a5c13b8222f9d0697c.tar.xz
main/perl-xml-simple: modernise, add check
Diffstat (limited to 'main/perl-xml-simple/APKBUILD')
-rw-r--r--main/perl-xml-simple/APKBUILD21
1 files changed, 14 insertions, 7 deletions
diff --git a/main/perl-xml-simple/APKBUILD b/main/perl-xml-simple/APKBUILD
index 56ebc9466a..4dce9906c0 100644
--- a/main/perl-xml-simple/APKBUILD
+++ b/main/perl-xml-simple/APKBUILD
@@ -1,8 +1,8 @@
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=perl-xml-simple
pkgver=2.24
-pkgrel=0
-pkgdesc="Simple XML parser for perl"
+pkgrel=1
+pkgdesc="Simple XML parser for Perl"
url="http://search.cpan.org/dist/XML-Simple/"
arch="noarch"
license="PerlArtistic"
@@ -11,15 +11,22 @@ depends="perl-xml-parser perl"
makedepends="perl-dev"
source="ftp://ftp.cpan.org/pub/CPAN/authors/id/G/GR/GRANTM/XML-Simple-$pkgver.tar.gz"
+builddir="$srcdir"/XML-Simple-$pkgver
+
build() {
- cd "$srcdir"/XML-Simple-$pkgver
- perl Makefile.PL INSTALLDIRS=vendor || return 1
- make || return 1
+ cd "$builddir"
+ perl Makefile.PL INSTALLDIRS=vendor
+ make
+}
+
+check() {
+ cd "$builddir"
+ make test
}
package() {
- cd "$srcdir"/XML-Simple-$pkgver
- make DESTDIR="$pkgdir" install || return 1
+ cd "$builddir"
+ make DESTDIR="$pkgdir" install
find "$pkgdir" -name '.packlist' -delete
find "$pkgdir" -name 'perllocal.pod' -delete
}