aboutsummaryrefslogtreecommitdiffstats
path: root/main/pkgconf
diff options
context:
space:
mode:
authorWilliam Pitcock <nenolod@dereferenced.org>2017-01-23 17:55:34 -0600
committerWilliam Pitcock <nenolod@dereferenced.org>2017-01-23 17:55:34 -0600
commit0d3f97cb3958361b544d4736993a6530e295973a (patch)
tree284e18d607c9fd06cf91212af425f1ce5f0c96ea /main/pkgconf
parent89c70a1a76678f57f85cf59f9c69ea4332256e11 (diff)
downloadaports-0d3f97cb3958361b544d4736993a6530e295973a.tar.bz2
aports-0d3f97cb3958361b544d4736993a6530e295973a.tar.xz
main/pkgconf: run tests again when not bootstrapping
Diffstat (limited to 'main/pkgconf')
-rw-r--r--main/pkgconf/APKBUILD11
1 files changed, 7 insertions, 4 deletions
diff --git a/main/pkgconf/APKBUILD b/main/pkgconf/APKBUILD
index b4f52d4010..fabb70a887 100644
--- a/main/pkgconf/APKBUILD
+++ b/main/pkgconf/APKBUILD
@@ -2,7 +2,7 @@
# Maintainer: William Pitcock <nenolod@dereferenced.org>
pkgname=pkgconf
pkgver=1.2.1
-pkgrel=0
+pkgrel=1
pkgdesc="development framework configuration tools"
url="https://github.com/pkgconf/pkgconf"
arch="all"
@@ -15,6 +15,9 @@ replaces="pkgconfig"
provides="pkgconfig=1"
source="https://distfiles.dereferenced.org/pkgconf/pkgconf-$pkgver.tar.xz"
subpackages="$pkgname-doc"
+if [ "$CHOST" = "$CBUILD" ]; then
+ makedepends="$makedepends kyua atf"
+fi
builddir="$srcdir"/pkgconf-$pkgver
@@ -31,9 +34,9 @@ build() {
--with-pkg-config-dir=/usr/local/lib/pkgconfig:/usr/local/share/pkgconfig:/usr/lib/pkgconfig:/usr/share/pkgconfig \
|| return 1
make || return 1
-# if [ "$CHOST" = "$CBUILD" ]; then
-# make check || return 1
-# fi
+ if [ "$CHOST" = "$CBUILD" ]; then
+ make check || return 1
+ fi
}
package() {