aboutsummaryrefslogtreecommitdiffstats
path: root/main/pngcrush/01-makefile-sanity.patch
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2013-07-25 08:58:17 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2013-07-25 08:58:17 +0000
commit58bcc48d91dc7396aaea2999fddb3ecdc70ec591 (patch)
tree835e5b07e10fb9faedde747c11afcd14bb4abfde /main/pngcrush/01-makefile-sanity.patch
parent4173e01c03de825c7f5da1156ebe76c645f2d3de (diff)
downloadaports-58bcc48d91dc7396aaea2999fddb3ecdc70ec591.tar.bz2
aports-58bcc48d91dc7396aaea2999fddb3ecdc70ec591.tar.xz
main/pngcrush: upgrade to 1.7.66
Diffstat (limited to 'main/pngcrush/01-makefile-sanity.patch')
-rw-r--r--main/pngcrush/01-makefile-sanity.patch40
1 files changed, 14 insertions, 26 deletions
diff --git a/main/pngcrush/01-makefile-sanity.patch b/main/pngcrush/01-makefile-sanity.patch
index 58c2640e8c..702bf77fac 100644
--- a/main/pngcrush/01-makefile-sanity.patch
+++ b/main/pngcrush/01-makefile-sanity.patch
@@ -1,35 +1,23 @@
---- pngcrush-1.7.27/Makefile.orig
-+++ pngcrush-1.7.27/Makefile
-@@ -11,8 +11,8 @@
- # macros --------------------------------------------------------------------
-
- # uncomment these 2 lines only if you are using an external copy of zlib:
--#ZINC = ../../zlib
--#ZLIB = ../../zlib
-+ZINC = ../../zlib
-+ZLIB = ../../zlib
-
- CC = gcc
- LD = gcc
-@@ -20,10 +20,10 @@
- #CFLAGS = -I. -O -Wall
- #CFLAGS = -I. -O2
- #CFLAGS = -I. -O3 -fomit-frame-pointer -Wall
--#CFLAGS = -I. -Os -fomit-frame-pointer -Wall
-+CFLAGS = -I. -Os -fomit-frame-pointer -Wall
- #CFLAGS = -I. -O3 -funroll-loops -fomit-frame-pointer -Wall -Wshadow
- # Work around zlib compiler bug in 1.2.6
--CFLAGS = -I. -O3 -funroll-loops -fomit-frame-pointer -Wall -Wshadow -DZ_SOLO
-+#CFLAGS = -I. -O3 -funroll-loops -fomit-frame-pointer -Wall -Wshadow -DZ_SOLO
- #CFLAGS = -I${ZINC} -I. -O3 -fomit-frame-pointer -Wall
+diff --git a/Makefile b/Makefile
+index e5de7d3..9c86fea 100644
+--- a/Makefile
++++ b/Makefile
+@@ -32,7 +32,7 @@ TOOFAR_OK=
+ #CFLAGS = -O2
+ #CFLAGS = -O2 -fomit-frame-pointer -Wall
+ #CFLAGS = -Os -fomit-frame-pointer -Wall
+-CFLAGS = -O3 -funroll-loops -fomit-frame-pointer -Wall -Wshadow
++CFLAGS ?= -O3 -funroll-loops -fomit-frame-pointer -Wall -Wshadow
# [note that -Wall is a gcc-specific compilation flag ("all warnings on")]
-@@ -37,15 +37,15 @@
+ LDFLAGS =
+@@ -41,16 +41,16 @@ E =
PNGCRUSH = pngcrush
-LIBS = -lm
-+LIBS = -lz -lm
++LIBS = -lm -lz
+ # uncomment one of these 2 lines only if you are using an external zlib:
#LIBS = -L${ZLIB} -lz -lm
#LIBS = ${ZLIB}/libz.a -lm