aboutsummaryrefslogtreecommitdiffstats
path: root/main/pngcrush
diff options
context:
space:
mode:
authorCarlo Landmeter <clandmeter@gmail.com>2016-08-09 18:45:37 +0000
committerCarlo Landmeter <clandmeter@gmail.com>2016-08-09 18:45:37 +0000
commit2ea51e89aba6e17cf36280271b4324e7dbbbddc2 (patch)
tree73a1a5fe07651ac626b16eeb825808a80c24c43e /main/pngcrush
parentf1388a00bfc66d66f575e7070dd218c1342ef660 (diff)
downloadaports-2ea51e89aba6e17cf36280271b4324e7dbbbddc2.tar.bz2
aports-2ea51e89aba6e17cf36280271b4324e7dbbbddc2.tar.xz
main/pngcrush: upgrade to 1.8.2
Diffstat (limited to 'main/pngcrush')
-rw-r--r--main/pngcrush/01-makefile-sanity.patch35
-rw-r--r--main/pngcrush/APKBUILD42
-rw-r--r--main/pngcrush/license.txt12
3 files changed, 13 insertions, 76 deletions
diff --git a/main/pngcrush/01-makefile-sanity.patch b/main/pngcrush/01-makefile-sanity.patch
deleted file mode 100644
index 702bf77fac..0000000000
--- a/main/pngcrush/01-makefile-sanity.patch
+++ /dev/null
@@ -1,35 +0,0 @@
-diff --git a/Makefile b/Makefile
-index e5de7d3..9c86fea 100644
---- a/Makefile
-+++ b/Makefile
-@@ -32,7 +32,7 @@ TOOFAR_OK=
- #CFLAGS = -O2
- #CFLAGS = -O2 -fomit-frame-pointer -Wall
- #CFLAGS = -Os -fomit-frame-pointer -Wall
--CFLAGS = -O3 -funroll-loops -fomit-frame-pointer -Wall -Wshadow
-+CFLAGS ?= -O3 -funroll-loops -fomit-frame-pointer -Wall -Wshadow
- # [note that -Wall is a gcc-specific compilation flag ("all warnings on")]
-
- LDFLAGS =
-@@ -41,16 +41,16 @@ E =
-
- PNGCRUSH = pngcrush
-
--LIBS = -lm
-+LIBS = -lm -lz
- # uncomment one of these 2 lines only if you are using an external zlib:
- #LIBS = -L${ZLIB} -lz -lm
- #LIBS = ${ZLIB}/libz.a -lm
-
- # uncomment these 4 lines only if you are NOT using an external copy of zlib:
--ZHDR = zlib.h
--ZOBJS = adler32$(O) compress$(O) crc32$(O) deflate$(O) \
-- infback$(O) inffast$(O) inflate$(O) inftrees$(O) \
-- trees$(O) uncompr$(O) zutil$(O)
-+#ZHDR = zlib.h
-+#ZOBJS = adler32$(O) compress$(O) crc32$(O) deflate$(O) \
-+# infback$(O) inffast$(O) inflate$(O) inftrees$(O) \
-+# trees$(O) uncompr$(O) zutil$(O)
-
- OBJS = pngcrush$(O) png$(O) pngerror$(O) pngget$(O) pngmem$(O) \
- pngpread$(O) pngread$(O) pngrio$(O) pngrtran$(O) pngrutil$(O) \
diff --git a/main/pngcrush/APKBUILD b/main/pngcrush/APKBUILD
index cf36bf273f..235c6da88e 100644
--- a/main/pngcrush/APKBUILD
+++ b/main/pngcrush/APKBUILD
@@ -1,7 +1,7 @@
# Contributor: Kiyoshi Aman <kiyoshi.aman@gmail.com>
# Maintainer: Fabian Affolter <fabian@affolter-engineering.ch>
pkgname=pngcrush
-pkgver=1.8.1
+pkgver=1.8.2
pkgrel=0
pkgdesc="PNG recompression utility"
url="http://pmt.sourceforge.net/pngcrush/"
@@ -9,42 +9,26 @@ arch="all"
license="zlib"
depends=""
depends_dev=""
-makedepends="$depends_dev zlib-dev"
+makedepends="$depends_dev zlib-dev libpng-dev"
install=""
subpackages=""
-source="http://downloads.sourceforge.net/project/pmt/${pkgname}/${pkgver}/${pkgname}-${pkgver}.tar.xz
- license.txt
- 01-makefile-sanity.patch"
+source="http://downloads.sourceforge.net/pmt/${pkgname}-${pkgver}-nolib.tar.xz"
-_builddir="$srcdir"/$pkgname-$pkgver
-prepare() {
- local i
- cd "$_builddir"
- for i in $source; do
- case $i in
- *.patch) msg $i; patch -p1 -i "$srcdir"/$i || return 1;;
- esac
- done
-}
+builddir="$srcdir"/$pkgname-$pkgver-nolib
build() {
- cd "$_builddir"
+ cd "$builddir"
make || return 1
}
package() {
- cd "$_builddir"
- install -D -m755 $pkgname "$pkgdir"/usr/bin/$pkgname || return 1
- install -D -m644 "$srcdir"/license.txt \
- "$pkgdir"/usr/share/licenses/pngcrush || return 1
+ cd "$builddir"
+ make DESTDIR="$pkgdir" install || return 1
}
-md5sums="ce116b11de49d75c0ed17bb5cf603b0d pngcrush-1.8.1.tar.xz
-8e5d194d4197e51add36722cd3248717 license.txt
-6a87145c0147355f2b0efb33f173a13b 01-makefile-sanity.patch"
-sha256sums="64921ca7e6013a2ff3f4e1387c95cec6c30fd7396069e5ddf68008993f46768b pngcrush-1.8.1.tar.xz
-2dedd4fae0c2c613411be8d7736d1d7b2f6573ff6eae3eb2f9f5e312e327c983 license.txt
-0cb9d31ff9a49c904b3e83c61dd7860adaa09f9aa11b69e5112edbb775da2ea2 01-makefile-sanity.patch"
-sha512sums="9c4b0ac384ca40aaf1202d2c762e1aa09d37a3fd30a17c1833817301aa82480b0d6ea9ecbee356fe4f40ed280980a9e4257456b3b6d67ee471ff8b3e49214015 pngcrush-1.8.1.tar.xz
-0302e756fb854ab0569c08254be522714396d554589b1d5a2822858c678eb16a78ee489d9170ebfcf7604eae27eb346c64646c4f1976e02bc258c749813fcf99 license.txt
-87965282c81907332063f4f735740093799c93c7994428200e4c52e559653aa7293dde4608250479c321f1a0eba2bddc3ccbb22d75fe9610b379075a28c612cd 01-makefile-sanity.patch"
+md5sums="f8f8cc7bf588fc0d076f521c4c3e262d pngcrush-1.8.2-nolib.tar.xz
+8e5d194d4197e51add36722cd3248717 license.txt"
+sha256sums="4a2b4a0445008f0d528cffebd143ca9b15ec41cbc5abb79ce244d6eedaf452b1 pngcrush-1.8.2-nolib.tar.xz
+2dedd4fae0c2c613411be8d7736d1d7b2f6573ff6eae3eb2f9f5e312e327c983 license.txt"
+sha512sums="f0bfd95a84c9eef48abe624ca8ea4c2064862e9b6330776f91d7647b2796b1221a9edccf8de73fdbad7031cdee0d161072ce44063c60a6a7880a51130fb5c0f9 pngcrush-1.8.2-nolib.tar.xz
+0302e756fb854ab0569c08254be522714396d554589b1d5a2822858c678eb16a78ee489d9170ebfcf7604eae27eb346c64646c4f1976e02bc258c749813fcf99 license.txt"
diff --git a/main/pngcrush/license.txt b/main/pngcrush/license.txt
deleted file mode 100644
index 641d19c0b7..0000000000
--- a/main/pngcrush/license.txt
+++ /dev/null
@@ -1,12 +0,0 @@
-Permission is hereby irrevocably granted to everyone to use, copy, modify,
-and distribute this source code, or portions hereof, or executable programs
-compiled from it, for any purpose, without payment of any fee, subject to
-the following restrictions:
-
-1. The origin of this source code must not be misrepresented.
-
-2. Altered versions must be plainly marked as such and must not be
- misrepresented as being the original source.
-
-3. This Copyright notice, disclaimer, and license may not be removed
- or altered from any source or altered source distribution.