aboutsummaryrefslogtreecommitdiffstats
path: root/main/postgresql-bdr
diff options
context:
space:
mode:
authorLeonardo Arena <rnalrd@alpinelinux.org>2017-04-27 09:00:35 +0000
committerLeonardo Arena <rnalrd@alpinelinux.org>2017-04-27 09:00:42 +0000
commit6ab4a7297e631751ff497b3d8716e925c223f4fc (patch)
tree13a83910715a743d487009aab7476b967c9da8e5 /main/postgresql-bdr
parent57f13553a6f6fbc05b8bd307bc40fa5d141ce24f (diff)
downloadaports-6ab4a7297e631751ff497b3d8716e925c223f4fc.tar.bz2
aports-6ab4a7297e631751ff497b3d8716e925c223f4fc.tar.xz
main/postgresql-bdr: upgrade to 9.4.10, modernize APKBUILD, disable check()
Diffstat (limited to 'main/postgresql-bdr')
-rw-r--r--main/postgresql-bdr/APKBUILD43
1 files changed, 16 insertions, 27 deletions
diff --git a/main/postgresql-bdr/APKBUILD b/main/postgresql-bdr/APKBUILD
index d476af8e6d..752ef18e4c 100644
--- a/main/postgresql-bdr/APKBUILD
+++ b/main/postgresql-bdr/APKBUILD
@@ -1,8 +1,8 @@
# Maintainer: Leonardo Arena <rnalrd@alpinelinux.org>
pkgname=postgresql-bdr
-pkgver=9.4.9_p1
+pkgver=9.4.10_p1
_ver=${pkgver/_p/_bdr}
-pkgrel=1
+pkgrel=0
pkgdesc="A sophisticated object-relational DBMS with bidirectional replication support (BDR)"
url="https://wiki.postgresql.org/wiki/BDR_Administration"
arch="all"
@@ -16,6 +16,8 @@ provides="postgresql"
patches="initdb.patch
postgresql-bdr-osxflags.patch
"
+#FIXME: cannot run with UID=0
+options="!check"
source="http://packages.2ndquadrant.com/postgresql-bdr94-2ndquadrant/tarballs/postgresql-bdr-$_ver.tar.bz2
$patches
$pkgname.initd
@@ -23,15 +25,11 @@ source="http://packages.2ndquadrant.com/postgresql-bdr94-2ndquadrant/tarballs/po
pgbdr-restore.initd
pgbdr-restore.confd
"
-
-_builddir="$srcdir"/$pkgname-$_ver
+builddir="$srcdir"/$pkgname-$_ver
prepare() {
- cd "$_builddir"
- for i in $patches; do
- msg "Applying patch $i"
- patch -p1 -i "$srcdir"/$i || return 1
- done
+ cd "$builddir"
+ default_prepare
# sanity check of conf.d
(
. "$srcdir"/$pkgname.confd
@@ -44,7 +42,7 @@ prepare() {
}
build() {
- cd "$_builddir"
+ cd "$builddir"
./configure \
--build=$CBUILD \
--host=$CHOST \
@@ -61,8 +59,13 @@ build() {
make FLEX="/usr/bin/flex" all || return 1
}
+check() {
+ cd "$builddir"
+ make check
+}
+
package() {
- cd "$_builddir"
+ cd "$builddir"
# Don't install docs
make DESTDIR="$pkgdir" install || return 1
@@ -83,26 +86,12 @@ package() {
contrib() {
depends=
pkgdesc="Extension modules distributed with PostgreSQL"
- cd "$_builddir"
+ cd "$builddir"
make DESTDIR="$subpkgdir" FLEX="/usr/bin/flex" -C contrib install \
|| return 1
}
-md5sums="f03ff68f69ddd20ee64f45ea71a96916 postgresql-bdr-9.4.9_bdr1.tar.bz2
-00f0fc07fb8447f7e174c4cee0661722 initdb.patch
-8dec4e9dc132304b5d33586acbcdbf90 postgresql-bdr-osxflags.patch
-076e302423991eb781349dfa9b1e7e5a postgresql-bdr.initd
-199747784fcba0a92e55283b90993d78 postgresql-bdr.confd
-498e1c28b2dc9a01a47edd7592bd1823 pgbdr-restore.initd
-bf45384752b320b369f1425939763178 pgbdr-restore.confd"
-sha256sums="7f8b52c29f16aca6bde023ee1b18953a92ebb6eb28a9a110d240372674c2f2ae postgresql-bdr-9.4.9_bdr1.tar.bz2
-36a65229bf31b20a95ff2e2cac1a6ece0c61afdcd0b544759ad12f34d1b98a39 initdb.patch
-d6f0f3eebca1c524c746c54be289e9816b00ad27fbfa834c2caee76c47daf155 postgresql-bdr-osxflags.patch
-dff07638f535c61cafae92ade1126476727abf5798e30bf18a170300fd6107ff postgresql-bdr.initd
-70ac7bf24556c16e6324b4efe76fba425bb09a2f7e74afbb5f988333eb8df724 postgresql-bdr.confd
-e1d91da4572902e8b150ce25c21eb012817634d6aad4ae6f9d9d344213b872b8 pgbdr-restore.initd
-31414d8b57c4cd2116b6014de3f1329875151910753fbd616daec4554866d02f pgbdr-restore.confd"
-sha512sums="f15695986d928d3704ca0097143536ee053b5d291b668220e78c1559bc87118858399d5445ec48f4c1a8509eacbb45678891ad0d4278ba290af24e8aabc8850c postgresql-bdr-9.4.9_bdr1.tar.bz2
+sha512sums="85bba9c7bec128d597b95fa7bfaabe42b3fea691a86f08307c6f9b254863a30448465191516baffe4851f7ea9b03b28fa7e2544e357de674ba54f0d84716b05b postgresql-bdr-9.4.10_bdr1.tar.bz2
6f7fdceb1a5aba3f00894ae88afdf25e5f9c7a0ffc00b11211011a6415ea73639d6a67f516cab66c6487484bab26ded3c93471d6d41ac0d3822926c22274f2ba initdb.patch
1973863bfc208ce20ca2dd82557ebbd4fcddd1219d6a80f2e83550d0110d39f034cb829cca3ee9208f513a24b032267b94559c740ddddb10a4f24c630194eb5e postgresql-bdr-osxflags.patch
85b863cfcae1db37ee914721fc9eb7e85ab90a77a65879bccb0bbf34eb044329425fae0411baff1d769a700ca63b4ab4040d145ca90e2d3728c3a74e61d9b4ff postgresql-bdr.initd