aboutsummaryrefslogtreecommitdiffstats
path: root/main/postgresql-pllua/APKBUILD
diff options
context:
space:
mode:
authorJakub Jirutka <jakub@jirutka.cz>2018-10-29 00:33:14 +0100
committerJakub Jirutka <jakub@jirutka.cz>2018-10-29 00:38:50 +0100
commit6b56a5da881f1eeaf9b734b8a9ce6e1ac68eea26 (patch)
tree9a12a7559e8f7930c464f603bb59aca8bd4b9e96 /main/postgresql-pllua/APKBUILD
parent6eb98f5845e7977b4f9d56bb9c72ae80b3e53392 (diff)
downloadaports-6b56a5da881f1eeaf9b734b8a9ce6e1ac68eea26.tar.bz2
aports-6b56a5da881f1eeaf9b734b8a9ce6e1ac68eea26.tar.xz
main/pllua: rename to postgresql-pllua
It's an extension for PostgreSQL, so it should be prefixed with postgresql-, the same as other extensions in aports.
Diffstat (limited to 'main/postgresql-pllua/APKBUILD')
-rw-r--r--main/postgresql-pllua/APKBUILD41
1 files changed, 41 insertions, 0 deletions
diff --git a/main/postgresql-pllua/APKBUILD b/main/postgresql-pllua/APKBUILD
new file mode 100644
index 0000000000..ca354695cf
--- /dev/null
+++ b/main/postgresql-pllua/APKBUILD
@@ -0,0 +1,41 @@
+# Contributor: Michael Mason <ms13sp@gmail.com>
+# Contributor: Jakub Jirutka <jakub@jirutka.cz>
+# Maintainer: Michael Mason <ms13sp@gmail.com>
+pkgname=postgresql-pllua
+_pkgname=pllua-ng
+pkgver=2.0
+_pkgver="REL_${pkgver//./_}"
+pkgrel=0
+pkgdesc="Procedural language for PostgreSQL using Lua"
+url="https://github.com/RhodiumToad/pllua-ng"
+arch="all"
+license="MIT"
+depends="postgresql"
+# LuaJIT does not support s390x.
+case "$CARCH" in
+ s390x) _lua=lua5.3;;
+ *) _lua=luajit; _luajit=luajit;;
+esac
+makedepends="postgresql-dev $_lua-dev"
+options="!check" # tests require running PostgreSQL
+provides="pllua=$pkgver-r$pkgrel" # for backward compatibility
+replaces="pllua" # for backward compatibility
+subpackages="$pkgname-dev"
+source="https://github.com/RhodiumToad/$_pkgname/archive/$_pkgver/$_pkgname-$_pkgver.tar.gz"
+builddir="$srcdir/$_pkgname-$_pkgver"
+
+build() {
+ cd "$builddir"
+
+ make ${_luajit:+"LUAJIT=$_luajit"} \
+ LUA_INCDIR=$(pkgconf --variable=includedir $_lua) \
+ LUALIB=$(pkgconf --libs $_lua) \
+ USE_PGXS=1
+}
+
+package() {
+ cd "$builddir"
+ make USE_PGXS=1 DESTDIR="$pkgdir" install
+}
+
+sha512sums="fa933c07460d7b292b7837b0b32601a7932d6037fb87db64e84e676d6a8487491750be365727ae4da1706081a733a435f8960b5d417d9ca446d32938aaf2e1a9 pllua-ng-REL_2_0.tar.gz"