aboutsummaryrefslogtreecommitdiffstats
path: root/main/postgresql/APKBUILD
diff options
context:
space:
mode:
authorJakub Jirutka <jakub@jirutka.cz>2017-11-04 22:23:15 +0100
committerJakub Jirutka <jakub@jirutka.cz>2017-11-04 23:29:17 +0100
commitd67ceb66a1ca9e1899071c9ef09fffba29fa0417 (patch)
treec0fb8f23864311c67c1ad04554a186609fe65bdb /main/postgresql/APKBUILD
parent26892ae1589a429eba33f402597fe1ad901ee3f9 (diff)
downloadaports-d67ceb66a1ca9e1899071c9ef09fffba29fa0417.tar.bz2
aports-d67ceb66a1ca9e1899071c9ef09fffba29fa0417.tar.xz
main/postgresql: upgrade to 10.0
Diffstat (limited to 'main/postgresql/APKBUILD')
-rw-r--r--main/postgresql/APKBUILD32
1 files changed, 11 insertions, 21 deletions
diff --git a/main/postgresql/APKBUILD b/main/postgresql/APKBUILD
index bd300a17d8..052e840da0 100644
--- a/main/postgresql/APKBUILD
+++ b/main/postgresql/APKBUILD
@@ -2,8 +2,8 @@
# Contributor: G.J.R. Timmer <gjr.timmer@gmail.com>
# Contributor: Jakub Jirutka <jakub@jirutka.cz>
pkgname=postgresql
-pkgver=9.6.5
-pkgrel=1
+pkgver=10.0
+pkgrel=0
pkgdesc="A sophisticated object-relational DBMS"
url="http://www.postgresql.org/"
arch="all"
@@ -25,6 +25,7 @@ source="https://ftp.postgresql.org/pub/source/v$pkgver/$pkgname-$pkgver.tar.bz2
initdb.patch
perl-rpath.patch
conf-unix_socket_directories.patch
+ disable-broken-tests.patch
$pkgname.initd
$pkgname.confd
pg-restore.initd
@@ -52,13 +53,6 @@ prepare() {
sed "s|@VERSION@|${pkgver%.*}|" "$srcdir"/$file > $file
done
- # XXX: Disable dblink and postgres_fdw tests. The tests fail due to
- # some linking issue, but there's no problem in runtime. I have no
- # clue what's wrong here.
- sed -Ei 's/^(REGRESS)/#\1/' \
- contrib/dblink/Makefile \
- contrib/postgres_fdw/Makefile
-
cp -al "$builddir" "$builddir"~py3
}
@@ -114,9 +108,7 @@ check() {
_run_tests src/test
_run_tests src/pl
-
- # Note: test_decoding fails when running in parallel.
- _run_tests contrib -j1
+ _run_tests contrib
}
package() {
@@ -165,16 +157,14 @@ client() {
mkdir -p "$subpkgdir"/usr/bin
mv clusterdb \
createdb \
- createlang \
createuser \
dropdb \
- droplang \
dropuser \
pg_basebackup \
pg_dump \
pg_dumpall \
pg_isready \
- pg_receivexlog \
+ pg_receivewal \
pg_recvlogical \
pg_restore \
psql \
@@ -206,9 +196,7 @@ pltcl() {
pkgdesc="PL/Tcl procedural language for PostgreSQL"
depends="pgtcl"
- _submv usr/bin/pltcl* \
- usr/lib/postgresql/pltcl.so \
- usr/share/postgresql/unknown.pltcl \
+ _submv usr/lib/postgresql/pltcl.so \
usr/share/postgresql/extension/pltcl*
install -m 644 "$srcdir"/pltcl_create_tables.sql \
@@ -279,7 +267,8 @@ _run_tests() {
local path="$1"; shift
msg "Running test suite at $path..."
- make -k -C "$path" $@ check MAX_CONNECTIONS=5 || {
+ # Note: some tests fail when running in parallel.
+ make -k -j 1 -C "$path" $@ check MAX_CONNECTIONS=5 || {
printf "\n%s\n\n" "Trying to find all regression.diffs files in build directory..." >&2
find "$path" -name regression.diffs | while read file; do
echo "=== test failure: $file ===" >&2
@@ -296,10 +285,11 @@ _submv() {
done
}
-sha512sums="ad35c27ea55b18005ea61b49d6994718df86519b3f99addd0ecb17ece1f1c34764eb5194f8961c45cfa75703d810baf54433f8538cfd43a70bd908e1e5878df9 postgresql-9.6.5.tar.bz2
-0b88eee78380ed6cf543c851ac1cea5fc50bb6ef1bb51e03694003f43d2bf4e117ff06657f958d0e9c00ace3b8a6bab6ed0bd017d23f80cfd203dab33da81d46 initdb.patch
+sha512sums="88295af13db77a85a604c925aa627d383fdac62c1185119bba87753ce4167a13aed0f055a7a1329b3051f8757c6ba7529baed00a564ef0cfbee685720f282678 postgresql-10.0.tar.bz2
+1f8e7dc58f5b0a12427cf2fd904ffa898a34f23f3332c8382b94e0d991c007289e7913a69e04498f3d93fc5701855796c207b4b1cc4a0b366f586050124d7fcc initdb.patch
5f9d8bb4957194069d01af8ab3abc6d4d83a7e7f8bd7ebe1caae5361d621a3e58f91b14b952958138a794e0a80bc154fbb7e3e78d211e2a95b9b7901335de854 perl-rpath.patch
8439a6fdfdea0a4867daeb8bc23d6c825f30c00d91d4c39f48653f5ee77341f23282ce03a77aad94b5369700f11d2cb28d5aee360e59138352a9ab331a9f9d0f conf-unix_socket_directories.patch
+1966b2a3971f56fbecd8daa45965236d487683e13300e5c000e595bbadbbe9d0e1301fbbfa034f452abe8a4e4a427781f772370b9ff392bb03fc11ee43c9dee7 disable-broken-tests.patch
224e80f9e62843fd248e625abdd0d9fe477729ff3f9a64fc5c86dd37bb7176d3504107fbed7ce578e3a1db7f60b8cf2abf5fe4862c81f76b6d026e29ca495cfc postgresql.initd
a6d9cba5c7270484b3a22083b2b37742faefb01b6643040050c92235840c601b2e206ebda32804937b729c6cf42c79a558b921900e52fc420df2a03b5f29e1f7 postgresql.confd
f5a1cba051e7d846c2d16703514601cb25729ed96b677c9bd0c199d64552120a8b14b238af01917fdb87106681e12dee6fff7447558155ba273e4f96be5e2892 pg-restore.initd