aboutsummaryrefslogtreecommitdiffstats
path: root/main/postgresql
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2014-03-11 10:13:09 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2014-03-11 10:15:15 +0000
commit8c01dee763f0986f49e7ae13749d3983947179ac (patch)
treeb2d75a12e4b5f2318c83f9e78836f5ca0a34ae02 /main/postgresql
parent29f97c6dcf8219497586ca4bf19dbfdb14ce9e38 (diff)
downloadaports-8c01dee763f0986f49e7ae13749d3983947179ac.tar.bz2
aports-8c01dee763f0986f49e7ae13749d3983947179ac.tar.xz
main/postgresql: fix pre-upgrade script
fixes #2751 (cherry picked from commit f8e89de0a10192799bed2c5de438dfce44fe1e8b) Conflicts: main/postgresql/APKBUILD
Diffstat (limited to 'main/postgresql')
-rw-r--r--main/postgresql/APKBUILD2
-rw-r--r--main/postgresql/postgresql.pre-upgrade2
2 files changed, 2 insertions, 2 deletions
diff --git a/main/postgresql/APKBUILD b/main/postgresql/APKBUILD
index 86044b6b56..9ca1c01ff4 100644
--- a/main/postgresql/APKBUILD
+++ b/main/postgresql/APKBUILD
@@ -1,7 +1,7 @@
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=postgresql
pkgver=9.3.3
-pkgrel=0
+pkgrel=1
pkgdesc="A sophisticated object-relational DBMS"
url="http://www.postgresql.org/"
arch="all"
diff --git a/main/postgresql/postgresql.pre-upgrade b/main/postgresql/postgresql.pre-upgrade
index bcdedaac88..6116252c19 100644
--- a/main/postgresql/postgresql.pre-upgrade
+++ b/main/postgresql/postgresql.pre-upgrade
@@ -3,7 +3,7 @@
new="$1"
old="$2"
-pgver=${new%*.}
+pgver=${new%.*}
compare=$(apk version -t "$old" $pgver)
# check if we upgrade from earlier than $pgver and if it is running