aboutsummaryrefslogtreecommitdiffstats
path: root/main/postgresql
diff options
context:
space:
mode:
authorJakub Jirutka <jakub@jirutka.cz>2017-04-15 23:35:19 +0200
committerJakub Jirutka <jakub@jirutka.cz>2017-04-15 23:37:29 +0200
commit3fbc8bcb1915fdfce4b9883ee9c745161fd62ab9 (patch)
treedd413304ecbb0064bc71bb75d26b715824cf13b7 /main/postgresql
parentfe338cc565ffa66933eb6c3b116bf12a90ffd8f1 (diff)
downloadaports-3fbc8bcb1915fdfce4b9883ee9c745161fd62ab9.tar.bz2
aports-3fbc8bcb1915fdfce4b9883ee9c745161fd62ab9.tar.xz
main/postgresql: change default unix_socket_directories
Diffstat (limited to 'main/postgresql')
-rw-r--r--main/postgresql/APKBUILD2
-rw-r--r--main/postgresql/conf-unix_socket_directories.patch14
2 files changed, 16 insertions, 0 deletions
diff --git a/main/postgresql/APKBUILD b/main/postgresql/APKBUILD
index 3497968323..5fab8dd413 100644
--- a/main/postgresql/APKBUILD
+++ b/main/postgresql/APKBUILD
@@ -23,6 +23,7 @@ subpackages="$pkgname-contrib $pkgname-dev $pkgname-doc libpq $pkgname-libs
source="ftp://ftp.$pkgname.org/pub/source/v$pkgver/$pkgname-$pkgver.tar.bz2
initdb.patch
perl-rpath.patch
+ conf-unix_socket_directories.patch
$pkgname.initd
$pkgname.confd
pg-restore.initd
@@ -241,6 +242,7 @@ _submv() {
sha512sums="7c9d61a591408e29d7dc70d6b28ecdf06edf7f8fbf4e014e60a1e4f841fd5734c74a820094f6153e10ef633d48ea73f2a85194f6d2cd519a8f7087a261e9e02b postgresql-9.6.2.tar.bz2
0b88eee78380ed6cf543c851ac1cea5fc50bb6ef1bb51e03694003f43d2bf4e117ff06657f958d0e9c00ace3b8a6bab6ed0bd017d23f80cfd203dab33da81d46 initdb.patch
5f9d8bb4957194069d01af8ab3abc6d4d83a7e7f8bd7ebe1caae5361d621a3e58f91b14b952958138a794e0a80bc154fbb7e3e78d211e2a95b9b7901335de854 perl-rpath.patch
+8439a6fdfdea0a4867daeb8bc23d6c825f30c00d91d4c39f48653f5ee77341f23282ce03a77aad94b5369700f11d2cb28d5aee360e59138352a9ab331a9f9d0f conf-unix_socket_directories.patch
224e80f9e62843fd248e625abdd0d9fe477729ff3f9a64fc5c86dd37bb7176d3504107fbed7ce578e3a1db7f60b8cf2abf5fe4862c81f76b6d026e29ca495cfc postgresql.initd
a6d9cba5c7270484b3a22083b2b37742faefb01b6643040050c92235840c601b2e206ebda32804937b729c6cf42c79a558b921900e52fc420df2a03b5f29e1f7 postgresql.confd
f5a1cba051e7d846c2d16703514601cb25729ed96b677c9bd0c199d64552120a8b14b238af01917fdb87106681e12dee6fff7447558155ba273e4f96be5e2892 pg-restore.initd
diff --git a/main/postgresql/conf-unix_socket_directories.patch b/main/postgresql/conf-unix_socket_directories.patch
new file mode 100644
index 0000000000..24c51e7b99
--- /dev/null
+++ b/main/postgresql/conf-unix_socket_directories.patch
@@ -0,0 +1,14 @@
+Creating socket in /tmp is silly, but unfortunately it's default location,
+so many clients expect it. Thus we preconfigure PostgreSQL to create socket
+both in /run/postgresql and /tmp.
+--- a/src/backend/utils/misc/postgresql.conf.sample
++++ b/src/backend/utils/misc/postgresql.conf.sample
+@@ -63,7 +63,7 @@
+ #port = 5432 # (change requires restart)
+ #max_connections = 100 # (change requires restart)
+ #superuser_reserved_connections = 3 # (change requires restart)
+-#unix_socket_directories = '/tmp' # comma-separated list of directories
++unix_socket_directories = '/run/postgresql,/tmp' # comma-separated list of directories
+ # (change requires restart)
+ #unix_socket_group = '' # (change requires restart)
+ #unix_socket_permissions = 0777 # begin with 0 to use octal notation