aboutsummaryrefslogtreecommitdiffstats
path: root/main/postgresql
diff options
context:
space:
mode:
authorJakub Jirutka <jakub@jirutka.cz>2017-09-04 21:53:46 +0200
committerJakub Jirutka <jakub@jirutka.cz>2017-09-05 01:16:14 +0200
commitae44e4ffe350c406064a8d2b7baef08c40bd4053 (patch)
treebc9af761c0ad6dbf07f0905bb4da64e2e09b27fe /main/postgresql
parent5b01e09b8828aab966fd5df662e6fc8008161cb5 (diff)
downloadaports-ae44e4ffe350c406064a8d2b7baef08c40bd4053.tar.bz2
aports-ae44e4ffe350c406064a8d2b7baef08c40bd4053.tar.xz
main/postgresql: build with -O2 instead of -Os
It should increase performance a bit for only 3% increase of the package size (computed on sum of (sub)packages).
Diffstat (limited to 'main/postgresql')
-rw-r--r--main/postgresql/APKBUILD8
1 files changed, 6 insertions, 2 deletions
diff --git a/main/postgresql/APKBUILD b/main/postgresql/APKBUILD
index 720effde98..4dd4d2c518 100644
--- a/main/postgresql/APKBUILD
+++ b/main/postgresql/APKBUILD
@@ -78,7 +78,11 @@ build() {
unset PYTHON
}
-_configure() {
+# Note: (...) instead of {...} is NOT a typo!
+_configure() (
+ export CFLAGS="${CFLAGS/-Os/-O2}"
+ export CPPFLAGS="${CPPFLAGS/-Os/-O2}"
+
./configure \
--build=$CBUILD \
--host=$CHOST \
@@ -93,7 +97,7 @@ _configure() {
--with-perl \
--with-python \
--with-tcl
-}
+)
package() {
cd "$builddir"