aboutsummaryrefslogtreecommitdiffstats
path: root/main/postgresql
diff options
context:
space:
mode:
authorAlan Messias Cordeiro de Lacerda <alancordeiro@gmail.com>2014-08-08 14:08:02 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2014-08-11 12:10:59 +0000
commit5a3102461f9d40667358c4ae4c28d57597859b16 (patch)
tree19c677ac706938985fd9d08a531f6f2205868b0c /main/postgresql
parent3819f423fbcf28cbb5b68a0f7bf6a820faf9fa44 (diff)
downloadaports-5a3102461f9d40667358c4ae4c28d57597859b16.tar.bz2
aports-5a3102461f9d40667358c4ae4c28d57597859b16.tar.xz
main/postgresql fix unix_socket_directories get_config parameter
Diffstat (limited to 'main/postgresql')
-rw-r--r--main/postgresql/APKBUILD8
-rw-r--r--main/postgresql/postgresql.initd2
2 files changed, 5 insertions, 5 deletions
diff --git a/main/postgresql/APKBUILD b/main/postgresql/APKBUILD
index 11e41279c5..172e24e600 100644
--- a/main/postgresql/APKBUILD
+++ b/main/postgresql/APKBUILD
@@ -1,7 +1,7 @@
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=postgresql
pkgver=9.3.5
-pkgrel=0
+pkgrel=1
pkgdesc="A sophisticated object-relational DBMS"
url="http://www.postgresql.org/"
arch="all"
@@ -88,19 +88,19 @@ contrib() {
md5sums="5059857c7d7e6ad83b6d55893a121b59 postgresql-9.3.5.tar.bz2
00f0fc07fb8447f7e174c4cee0661722 initdb.patch
-a5ee4dc50d690efc124c8a4986458e59 postgresql.initd
+901e76a1b9eedd08893f1aee23637f16 postgresql.initd
9741f3d5f0611ce39f85f70f2cab2b00 postgresql.confd
d2a51db4436e550d56bb1e96699faef4 pg-restore.initd
bf45384752b320b369f1425939763178 pg-restore.confd"
sha256sums="14176ffb1f90a189e7626214365be08ea2bfc26f26994bafb4235be314b9b4b0 postgresql-9.3.5.tar.bz2
36a65229bf31b20a95ff2e2cac1a6ece0c61afdcd0b544759ad12f34d1b98a39 initdb.patch
-43a2e06ccd37d2d5ee62ac68bd33bdb65bb193675a58132273cc066579b47e45 postgresql.initd
+c173ffd6c3ce4348fdcee8c8511a2e09af3bed350a3cdef6cadc1700e79063b4 postgresql.initd
7fd24959d5fa49b1405cb94438665f060335266ea20224f234c6bcb5dce3403b postgresql.confd
d73701e9a5fff2d7088ee50d7c7fc8a2fa19f651237d8b880c579e0e09515609 pg-restore.initd
31414d8b57c4cd2116b6014de3f1329875151910753fbd616daec4554866d02f pg-restore.confd"
sha512sums="a49bc8ea7635be5082044f5ebd6b81de7198583aedb072dffec8425521af90f2cb8e9f6e7b55b361ff24cbebc0670afefe365e8f5b80b8248ddf492b8092a746 postgresql-9.3.5.tar.bz2
6f7fdceb1a5aba3f00894ae88afdf25e5f9c7a0ffc00b11211011a6415ea73639d6a67f516cab66c6487484bab26ded3c93471d6d41ac0d3822926c22274f2ba initdb.patch
-3c6a87d21e15337c20aec9fecf87bb01af72f26ff9a1c58339ab0415500290581fd6017536a968380630746a89ff74620b06f906ea90dc39889df8ce2335978c postgresql.initd
+861e4f5091cb2b3c80ce0afddb09275ed7e130c717235cdb7a3e58599424f13c11855e158e584b7342df18d47f7a7d71e945b8899337f82a3ea814a11fff39c0 postgresql.initd
17f0a81cc06a76aeadd0b1bd14cffffee2c64405615ef13895403e854569f936b295c54786d2c5aa84dc617edb615257c05a8e04185151f88a4e762eb7e67844 postgresql.confd
e7f8e08edc54c54c513786f8ea34cb6deac61106cff8004fbe56b9b32b22a4d5acdff256e864ef242b91d7704595fd9ec27ccbcef70da5d5c85f049d92304bf2 pg-restore.initd
c14a5684e914abb3b0ee71bbf15eed71a9264deacaa404a6e3af6bfc330d93e7598624d0ed11a94263106cc660f7f54c8ff57e759033cf606a795f69ff6c1c7c pg-restore.confd"
diff --git a/main/postgresql/postgresql.initd b/main/postgresql/postgresql.initd
index 2ca8420e10..d47c50540a 100644
--- a/main/postgresql/postgresql.initd
+++ b/main/postgresql/postgresql.initd
@@ -21,7 +21,7 @@ get_config() {
checkconfig() {
configured_port=$(get_config port)
: ${configured_port:=${PGPORT:-5432}}
- socket_path=$(get_config unix_socket_directory)
+ socket_path=$(get_config unix_socket_directories)
: ${socket_path:=/var/run/postgresql}
checkpath -d -m 0770 -o postgres:postgres ${socket_path}