aboutsummaryrefslogtreecommitdiffstats
path: root/main/ppp/musl-fix-headers.patch
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2014-06-03 09:12:29 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2014-06-03 09:21:26 +0000
commit28648190fd6f9d06d4db3f636dd91af48f293158 (patch)
tree0d2c64a20a3bd54951221dd8a3b451972410c2a4 /main/ppp/musl-fix-headers.patch
parent80e7a7e86c28c23fff4fd31edce1fdf48727a6ce (diff)
downloadaports-28648190fd6f9d06d4db3f636dd91af48f293158.tar.bz2
aports-28648190fd6f9d06d4db3f636dd91af48f293158.tar.xz
main/ppp: upgrade to 2.4.6 and ship net/ppp_defs.h
Diffstat (limited to 'main/ppp/musl-fix-headers.patch')
-rw-r--r--main/ppp/musl-fix-headers.patch128
1 files changed, 71 insertions, 57 deletions
diff --git a/main/ppp/musl-fix-headers.patch b/main/ppp/musl-fix-headers.patch
index 6a43cc0fd1..d24f628968 100644
--- a/main/ppp/musl-fix-headers.patch
+++ b/main/ppp/musl-fix-headers.patch
@@ -1,5 +1,7 @@
---- ppp-2.4.5.orig/include/net/ppp_defs.h
-+++ ppp-2.4.5/include/net/ppp_defs.h
+diff --git a/include/net/ppp_defs.h b/include/net/ppp_defs.h
+index b06eda5..dafa36c 100644
+--- a/include/net/ppp_defs.h
++++ b/include/net/ppp_defs.h
@@ -38,6 +38,8 @@
#ifndef _PPP_DEFS_H_
#define _PPP_DEFS_H_
@@ -9,18 +11,23 @@
/*
* The basic PPP frame.
*/
---- ppp-2.4.5.orig/pppd/ipv6cp.c
-+++ ppp-2.4.5/pppd/ipv6cp.c
-@@ -151,6 +151,7 @@
- */
+diff --git a/pppd/Makefile.linux b/pppd/Makefile.linux
+index a74c914..7acd2cf 100644
+--- a/pppd/Makefile.linux
++++ b/pppd/Makefile.linux
+@@ -126,7 +126,7 @@ LIBS += -lcrypt
+ endif
- #include <stdio.h>
-+#include <stdlib.h>
- #include <string.h>
- #include <unistd.h>
- #include <netdb.h>
---- ppp-2.4.5.orig/pppd/magic.h
-+++ ppp-2.4.5/pppd/magic.h
+ ifdef USE_LIBUTIL
+-CFLAGS += -DHAVE_LOGWTMP=1
++#CFLAGS += -DHAVE_LOGWTMP=1
+ LIBS += -lutil
+ endif
+
+diff --git a/pppd/magic.h b/pppd/magic.h
+index c81213b..305aece 100644
+--- a/pppd/magic.h
++++ b/pppd/magic.h
@@ -42,6 +42,8 @@
* $Id: magic.h,v 1.5 2003/06/11 23:56:26 paulus Exp $
*/
@@ -30,31 +37,11 @@
void magic_init __P((void)); /* Initialize the magic number generator */
u_int32_t magic __P((void)); /* Returns the next magic number */
---- ppp-2.4.5.orig/pppd/sys-linux.c
-+++ ppp-2.4.5/pppd/sys-linux.c
-@@ -102,19 +102,11 @@
- #define MAX_ADDR_LEN 7
- #endif
-
--#if __GLIBC__ >= 2
- #include <asm/types.h> /* glibc 2 conflicts with linux/types.h */
- #include <net/if.h>
- #include <net/if_arp.h>
- #include <net/route.h>
- #include <netinet/if_ether.h>
--#else
--#include <linux/types.h>
--#include <linux/if.h>
--#include <linux/if_arp.h>
--#include <linux/route.h>
--#include <linux/if_ether.h>
--#endif
- #include <netinet/in.h>
- #include <arpa/inet.h>
-
---- ppp-2.4.5.orig/pppd/plugins/rp-pppoe/if.c
-+++ ppp-2.4.5/pppd/plugins/rp-pppoe/if.c
-@@ -30,10 +30,6 @@
+diff --git a/pppd/plugins/rp-pppoe/if.c b/pppd/plugins/rp-pppoe/if.c
+index 91e9a57..9c0fac3 100644
+--- a/pppd/plugins/rp-pppoe/if.c
++++ b/pppd/plugins/rp-pppoe/if.c
+@@ -30,10 +30,6 @@ static char const RCSID[] =
#include <linux/if_packet.h>
#endif
@@ -65,18 +52,22 @@
#ifdef HAVE_ASM_TYPES_H
#include <asm/types.h>
#endif
---- ppp-2.4.5.orig/pppd/plugins/rp-pppoe/plugin.c
-+++ ppp-2.4.5/pppd/plugins/rp-pppoe/plugin.c
-@@ -46,7 +46,6 @@
+diff --git a/pppd/plugins/rp-pppoe/plugin.c b/pppd/plugins/rp-pppoe/plugin.c
+index a8c2bb4..ca34d79 100644
+--- a/pppd/plugins/rp-pppoe/plugin.c
++++ b/pppd/plugins/rp-pppoe/plugin.c
+@@ -46,7 +46,6 @@ static char const RCSID[] =
#include <unistd.h>
#include <fcntl.h>
#include <signal.h>
-#include <net/ethernet.h>
#include <net/if_arp.h>
#include <linux/ppp_defs.h>
- #include <linux/if_ppp.h>
---- ppp-2.4.5.orig/pppd/plugins/rp-pppoe/pppoe-discovery.c
-+++ ppp-2.4.5/pppd/plugins/rp-pppoe/pppoe-discovery.c
+ #include <linux/if_pppox.h>
+diff --git a/pppd/plugins/rp-pppoe/pppoe-discovery.c b/pppd/plugins/rp-pppoe/pppoe-discovery.c
+index 3d3bf4e..b5f82d3 100644
+--- a/pppd/plugins/rp-pppoe/pppoe-discovery.c
++++ b/pppd/plugins/rp-pppoe/pppoe-discovery.c
@@ -27,10 +27,6 @@
#include <linux/if_packet.h>
#endif
@@ -88,9 +79,20 @@
#ifdef HAVE_ASM_TYPES_H
#include <asm/types.h>
#endif
---- ppp-2.4.5.orig/pppd/plugins/rp-pppoe/pppoe.h
-+++ ppp-2.4.5/pppd/plugins/rp-pppoe/pppoe.h
-@@ -86,18 +86,6 @@
+@@ -55,6 +51,8 @@ void die(int status)
+ exit(status);
+ }
+
++#define error(x...) fprintf(stderr, x)
++
+ /* Initialize frame types to RFC 2516 values. Some broken peers apparently
+ use different frame types... sigh... */
+
+diff --git a/pppd/plugins/rp-pppoe/pppoe.h b/pppd/plugins/rp-pppoe/pppoe.h
+index 9ab2eee..4d68147 100644
+--- a/pppd/plugins/rp-pppoe/pppoe.h
++++ b/pppd/plugins/rp-pppoe/pppoe.h
+@@ -86,18 +86,6 @@ typedef unsigned long UINT32_t;
#include <netinet/in.h>
@@ -109,15 +111,27 @@
/* Ethernet frame types according to RFC 2516 */
#define ETH_PPPOE_DISCOVERY 0x8863
-Only in ppp-2.4.5/pppd/plugins/rp-pppoe: pppoe-discovery
---- ppp-2.4.5.orig/pppd/plugins/rp-pppoe/pppoe-discovery.c
-+++ ppp-2.4.5/pppd/plugins/rp-pppoe/pppoe-discovery.c
-@@ -51,6 +51,8 @@
- exit(status);
- }
+diff --git a/pppd/sys-linux.c b/pppd/sys-linux.c
+index 6d71530..86d224e 100644
+--- a/pppd/sys-linux.c
++++ b/pppd/sys-linux.c
+@@ -102,19 +102,11 @@
+ #define MAX_ADDR_LEN 7
+ #endif
-+#define error(x...) fprintf(stderr, x)
-+
- /* Initialize frame types to RFC 2516 values. Some broken peers apparently
- use different frame types... sigh... */
+-#if __GLIBC__ >= 2
+ #include <asm/types.h> /* glibc 2 conflicts with linux/types.h */
+ #include <net/if.h>
+ #include <net/if_arp.h>
+ #include <net/route.h>
+ #include <netinet/if_ether.h>
+-#else
+-#include <linux/types.h>
+-#include <linux/if.h>
+-#include <linux/if_arp.h>
+-#include <linux/route.h>
+-#include <linux/if_ether.h>
+-#endif
+ #include <netinet/in.h>
+ #include <arpa/inet.h>