aboutsummaryrefslogtreecommitdiffstats
path: root/main/protobuf
diff options
context:
space:
mode:
authorTBK <tbk@jjtc.dk>2017-12-01 02:17:43 +0100
committerLeonardo Arena <rnalrd@alpinelinux.org>2017-12-14 13:31:20 +0000
commit10220e1b836e96b1c50f3692ee61204b47939c8b (patch)
tree28cd597477920dd9317784752460905de1b6f12e /main/protobuf
parent160eff4125d01b39391dd1724a40a8323f47c6aa (diff)
downloadaports-10220e1b836e96b1c50f3692ee61204b47939c8b.tar.bz2
aports-10220e1b836e96b1c50f3692ee61204b47939c8b.tar.xz
main/protobuf: upgrade to 3.5.0
Diffstat (limited to 'main/protobuf')
-rw-r--r--main/protobuf/APKBUILD8
-rw-r--r--main/protobuf/musl-fix.patch5
2 files changed, 6 insertions, 7 deletions
diff --git a/main/protobuf/APKBUILD b/main/protobuf/APKBUILD
index 62574f7ad0..20f2acf35f 100644
--- a/main/protobuf/APKBUILD
+++ b/main/protobuf/APKBUILD
@@ -2,8 +2,8 @@
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=protobuf
_gemname=google-protobuf
-pkgver=3.4.1
-pkgrel=1
+pkgver=3.5.0
+pkgrel=0
pkgdesc="Library for extensible, efficient structure packing"
url="https://github.com/google/protobuf"
arch="all"
@@ -86,6 +86,6 @@ vim() {
"$subpkgdir"/usr/share/vim/vimfiles/syntax/proto.vim
}
-sha512sums="471e52198fa878a79183dc8fbc39d9c65239be4d9dff799e12281ee9b1af61a427584534b1baae1773bc6e4c86467f89ca2e7911a21effd86bc5f40cc7d94c34 protobuf-3.4.1.tar.gz
-66b430c81f34f49a86dfca50edbb517e4ad1a5ea922625b6266410c5feacfb621fe583c2998ac8994c6de45470652d2408c6c731d9746b74891a627564ca01f0 musl-fix.patch
+sha512sums="7b9477d298f604067b9ebab72a99adae8a31249b3ea3fd0e70fd4ac77180bec83131193b2642a624fbb7cc5eae9f1b369bffec9297b49b04207ae50a4071aaa4 protobuf-3.5.0.tar.gz
+b321cf82a959263d3173cc1c5cce4c77d4720f5dd824f20c98abb94f11eccf2907afce8b8a86340b4fc1bd1c7d5df1afca4672c17a97feb089521e167b20c70f musl-fix.patch
e1f6483b7e8d38b07cd01883bda439b2017fa0a87626fa49628f1d2042b5097ba8a68bdf1a03cd385e3e9a7c0bd2af6fbccec25e1c061617c3cceccabd17dce4 trim-rakefile.patch"
diff --git a/main/protobuf/musl-fix.patch b/main/protobuf/musl-fix.patch
index d7ab194a93..d53ee43698 100644
--- a/main/protobuf/musl-fix.patch
+++ b/main/protobuf/musl-fix.patch
@@ -1,10 +1,9 @@
seems like both musl libc and android has byteswap.h
diff --git a/src/google/protobuf/stubs/port.h b/src/google/protobuf/stubs/port.h
-index 376be5f..21223f4 100644
--- a/src/google/protobuf/stubs/port.h
+++ b/src/google/protobuf/stubs/port.h
-@@ -87,7 +87,7 @@
+@@ -93,7 +93,7 @@
#include <stdlib.h> // NOLINT(build/include)
#elif defined(__APPLE__)
#include <libkern/OSByteOrder.h>
@@ -13,7 +12,7 @@ index 376be5f..21223f4 100644
#include <byteswap.h> // IWYU pragma: export
#endif
-@@ -299,7 +299,7 @@ inline void GOOGLE_UNALIGNED_STORE64(void *p, uint64 v) {
+@@ -366,7 +366,7 @@
#define bswap_32(x) OSSwapInt32(x)
#define bswap_64(x) OSSwapInt64(x)