aboutsummaryrefslogtreecommitdiffstats
path: root/main/putty
diff options
context:
space:
mode:
authorChristian Kampka <christian@kampka.net>2015-11-06 16:21:14 +0100
committerNatanael Copa <ncopa@alpinelinux.org>2015-11-09 08:24:29 +0000
commit75392a341d04a2323bd87237faeecdf87a883c6e (patch)
treed8c14ef8f33bffb962d088ca769f36aaefb9d0d7 /main/putty
parent43e080527850b17abecbf8b62bee239460cba01a (diff)
downloadaports-75392a341d04a2323bd87237faeecdf87a883c6e.tar.bz2
aports-75392a341d04a2323bd87237faeecdf87a883c6e.tar.xz
main/putty: new upstream version 0.65
Diffstat (limited to 'main/putty')
-rw-r--r--main/putty/APKBUILD17
-rw-r--r--main/putty/fix-big-int-type.patch14
2 files changed, 25 insertions, 6 deletions
diff --git a/main/putty/APKBUILD b/main/putty/APKBUILD
index ba3d455840..729c046ecc 100644
--- a/main/putty/APKBUILD
+++ b/main/putty/APKBUILD
@@ -1,7 +1,7 @@
# Maintainer: Jeff Bilyk <jbilyk@alpinelinux.org>
pkgname=putty
-pkgver=0.64
-pkgrel=1
+pkgver=0.65
+pkgrel=0
pkgdesc="SSH and telnet client"
url="http://www.chiark.greenend.org.uk/~sgtatham/putty/"
arch="all"
@@ -11,7 +11,9 @@ depends_dev=
makedepends="$depends_dev"
install=""
subpackages="$pkgname-doc"
-source="http://the.earth.li/~sgtatham/putty/latest/putty-$pkgver.tar.gz"
+source="http://the.earth.li/~sgtatham/putty/latest/putty-$pkgver.tar.gz
+fix-big-int-type.patch
+"
_builddir="$srcdir"/putty-$pkgver
prepare() {
@@ -39,6 +41,9 @@ package() {
make DESTDIR="$pkgdir" install || return 1
}
-md5sums="75ff711e8b7cc9e0073bc511e1c1c14a putty-0.64.tar.gz"
-sha256sums="2a46c97a184144e3ec2392aca9acc64d062317a3a38b9a5f623a147eda5f3821 putty-0.64.tar.gz"
-sha512sums="ba4d4086b8edcb6388924bf3d9b018841be36a9dbf298271c9d2ed063aae9854093e9ff6808bd1f65669d78369548639eb3c95fdec5e3f0daee4b1c7bb603051 putty-0.64.tar.gz"
+md5sums="fe7220d2c1afc27805f976fc21afffd0 putty-0.65.tar.gz
+a9a76a4b889eaa3c25bce60c2c3d1211 fix-big-int-type.patch"
+sha256sums="d543c1fd4944ea51d46d4abf31bfb8cde9bd1c65cb36dc6b83e51ce875660ca0 putty-0.65.tar.gz
+77cf14b0c1b793c79c3f80a6e11b57ca281a155a3b01c96ec052ec1cd37d849b fix-big-int-type.patch"
+sha512sums="cfb3e5437a920aa11bccedf1bd43a538a51ec3777a6d1dba9e9714c3b3699eaf1f4eb027a8f5fd6425f9909564a28b607f465b1f2b2e1250059b04b9a9d40569 putty-0.65.tar.gz
+7dae793a7f9c5248f10ebf456087c01459c99bc8ab931b06a9aa09d70ef010a06bf7b248c38b03ddd0b76d1a35d3b32a095ac99a22d08aa170ce0d100f5dffb7 fix-big-int-type.patch"
diff --git a/main/putty/fix-big-int-type.patch b/main/putty/fix-big-int-type.patch
new file mode 100644
index 0000000000..77c17284b2
--- /dev/null
+++ b/main/putty/fix-big-int-type.patch
@@ -0,0 +1,14 @@
+diff --git a/sshbn.h.orig b/sshbn.h
+index a043241..f2a3217 100644
+--- a/sshbn.h.orig
++++ b/sshbn.h
+@@ -26,7 +26,8 @@
+ * using the same 'two machine registers' kind of code generation that
+ * 32-bit targets use for 64-bit ints. If we have one of these, we can
+ * use a 64-bit BignumInt and a 128-bit BignumDblInt. */
+-typedef __uint64_t BignumInt;
++#include <stdint.h>
++typedef uint64_t BignumInt;
+ typedef __uint128_t BignumDblInt;
+ #define BIGNUM_INT_MASK 0xFFFFFFFFFFFFFFFFULL
+ #define BIGNUM_TOP_BIT 0x8000000000000000ULL