aboutsummaryrefslogtreecommitdiffstats
path: root/main/py-click
diff options
context:
space:
mode:
authorJakub Jirutka <jakub@jirutka.cz>2016-10-01 20:20:30 +0200
committerJakub Jirutka <jakub@jirutka.cz>2016-10-01 20:23:32 +0200
commitc522df2d4a55f46427f0decbded4ba2590555515 (patch)
tree3fa3a49a28c48d297fbda76096bdfba246418a84 /main/py-click
parent4f5da7f85993adc9b7cc5b3aacc24a204ba0d1e0 (diff)
downloadaports-c522df2d4a55f46427f0decbded4ba2590555515.tar.bz2
aports-c522df2d4a55f46427f0decbded4ba2590555515.tar.xz
main/py-click: move from community
This package is needed for main/py-flask 0.11.x.
Diffstat (limited to 'main/py-click')
-rw-r--r--main/py-click/APKBUILD49
1 files changed, 49 insertions, 0 deletions
diff --git a/main/py-click/APKBUILD b/main/py-click/APKBUILD
new file mode 100644
index 0000000000..f4b1a7a935
--- /dev/null
+++ b/main/py-click/APKBUILD
@@ -0,0 +1,49 @@
+# Contributor: Fabian Affolter <fabian@affolter-engineering.ch>
+# Maintainer: Fabian Affolter <fabian@affolter-engineering.ch>
+pkgname=py-click
+_pkgname=click
+pkgver=6.6
+pkgrel=0
+pkgdesc="A simple wrapper around optparse for powerful command line utilities"
+url="http://click.pocoo.org/"
+arch="noarch"
+license="BSD"
+depends=""
+makedepends="python2-dev python3-dev py-setuptools"
+subpackages="py2-${pkgname#py-}:_py2 py3-${pkgname#py-}:_py3"
+source="https://files.pythonhosted.org/packages/source/${_pkgname:0:1}/$_pkgname/$_pkgname-$pkgver.tar.gz"
+builddir="$srcdir/$_pkgname-$pkgver"
+
+build() {
+ cd "$builddir"
+
+ python2 setup.py build || return 1
+ python3 setup.py build
+}
+
+package() {
+ mkdir -p "$pkgdir"
+}
+
+_py2() {
+ replaces="$pkgname"
+ _py python2
+}
+
+_py3() {
+ _py python3
+}
+
+_py() {
+ local python="$1"
+ pkgdesc="$pkgdesc (for $python)"
+ depends="$depends $python"
+ install_if="$pkgname=$pkgver-r$pkgrel $python"
+
+ cd "$builddir"
+ $python setup.py install --prefix=/usr --root="$subpkgdir"
+}
+
+md5sums="d0b09582123605220ad6977175f3e51d click-6.6.tar.gz"
+sha256sums="cc6a19da8ebff6e7074f731447ef7e112bd23adf3de5c597cf9989f2fd8defe9 click-6.6.tar.gz"
+sha512sums="5650cfe6c8b55a7e823e22248964143278d61383dac63497508a864807f1950f9dd5d76ce6a501e589dd81fed6e2a1248d3f8973be25a91950896b7408dc88bc click-6.6.tar.gz"