aboutsummaryrefslogtreecommitdiffstats
path: root/main/py-funcsigs
diff options
context:
space:
mode:
authorJakub Jirutka <jakub@jirutka.cz>2016-07-06 19:40:49 +0200
committerBartłomiej Piotrowski <b@bpiotrowski.pl>2016-07-08 18:44:26 +0200
commit93be634436eb466cacd4ec5ea4fcfb811bde9975 (patch)
tree7c977912e3836f0929ceb6ae252d38060bd94dfc /main/py-funcsigs
parentd093991db57b4a583f10dc4bed68281dfa91e566 (diff)
downloadaports-93be634436eb466cacd4ec5ea4fcfb811bde9975.tar.bz2
aports-93be634436eb466cacd4ec5ea4fcfb811bde9975.tar.xz
main/*: change source URL pypi.python.org to files.pythonhosted.org
See https://bitbucket.org/pypa/pypi/issues/438/backwards-compatible-un-hashed-package#comment-27734791
Diffstat (limited to 'main/py-funcsigs')
-rw-r--r--main/py-funcsigs/APKBUILD6
1 files changed, 4 insertions, 2 deletions
diff --git a/main/py-funcsigs/APKBUILD b/main/py-funcsigs/APKBUILD
index feabbb4413..913b4aeb94 100644
--- a/main/py-funcsigs/APKBUILD
+++ b/main/py-funcsigs/APKBUILD
@@ -1,6 +1,7 @@
# Contributor: Francesco Colista <fcolista@alpinelinux.org>
# Maintainer: Francesco Colista <fcolista@alpinelinux.org>
pkgname=py-funcsigs
+_pkgname=funcsigs
pkgver=1.0.2
pkgrel=0
pkgdesc="Python function signatures from PEP362 for Python 2.6, 2.7 and 3.2+"
@@ -12,8 +13,9 @@ depends_dev=""
makedepends="$depends_dev python-dev py-setuptools"
install=""
subpackages=""
-source="https://pypi.python.org/packages/94/4a/db842e7a0545de1cdb0439bb80e6e42dfe82aaeaadd4072f2263a4fbed23/${pkgname/py-/}-$pkgver.tar.gz"
-builddir="$srcdir"/${pkgname/py-/}-$pkgver
+source="https://files.pythonhosted.org/packages/source/${_pkgname:0:1}/$_pkgname/$_pkgname-$pkgver.tar.gz"
+builddir="$srcdir/$_pkgname-$pkgver"
+
build () {
cd "$builddir"
python setup.py build || return 1