aboutsummaryrefslogtreecommitdiffstats
path: root/main/py-gtk
diff options
context:
space:
mode:
authorAndrew Manison <amanison@anselsystems.com>2012-01-08 22:20:20 +0000
committerAndrew Manison <amanison@anselsystems.com>2012-01-08 22:20:20 +0000
commit299b29fa67980b70dc33e3a5488fd14201b5ea4e (patch)
treec85b54b3276a4839a3a303c360db91cf61403d8c /main/py-gtk
parentcb14f0100ce084cd2d6960dc97705fedd58566bc (diff)
downloadaports-299b29fa67980b70dc33e3a5488fd14201b5ea4e.tar.bz2
aports-299b29fa67980b70dc33e3a5488fd14201b5ea4e.tar.xz
main/py-gtk: Build fix to remove libtool archives before package split
Diffstat (limited to 'main/py-gtk')
-rw-r--r--main/py-gtk/APKBUILD4
1 files changed, 3 insertions, 1 deletions
diff --git a/main/py-gtk/APKBUILD b/main/py-gtk/APKBUILD
index ffa498bb56..674074000c 100644
--- a/main/py-gtk/APKBUILD
+++ b/main/py-gtk/APKBUILD
@@ -1,7 +1,7 @@
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=py-gtk
pkgver=2.24.0
-pkgrel=2
+pkgrel=3
pkgdesc="Python bindings for the GTK widget set"
url="http://www.pygtk.org/"
arch="all"
@@ -28,11 +28,13 @@ package() {
cd "$_builddir"
make DESTDIR="$pkgdir" install || return 1
install -m644 gtk/gtk-extrafuncs.defs ""$pkgdir"/usr/share/pygtk/2.0/defs/" || return 1
+ rm "$pkgdir"/usr/lib/python2.7/site-packages/gtk-2.0/gtk/*.la
}
demo() {
pkgdesc="Demonstration of pygtk"
depends="py-gtk"
+ rm "$pkgdir"/usr/lib/python2.7/site-packages/gtk-2.0/*.la
mkdir -p "$subpkgdir"/usr/bin "$subpkgdir"/usr/lib/pygtk/2.0
mv "$pkgdir"/usr/bin/pygtk-demo "$subpkgdir"/usr/bin/
mv "$pkgdir"/usr/lib/pygtk/2.0/*demo* \