aboutsummaryrefslogtreecommitdiffstats
path: root/main/py-hiredis/system-hiredis.patch
diff options
context:
space:
mode:
authorEivind Uggedal <eivind@uggedal.com>2014-05-26 08:32:33 +0000
committerEivind Uggedal <eivind@uggedal.com>2014-05-26 08:32:33 +0000
commit29ae0847ba2b4c11d474e9c8ff820b8f6b33afcd (patch)
treedb3d27f3de02b41bd04697b082ff5ef32362b188 /main/py-hiredis/system-hiredis.patch
parent6676a28d90aa46ed21ca774afbd1227e6cef8ee7 (diff)
downloadaports-29ae0847ba2b4c11d474e9c8ff820b8f6b33afcd.tar.bz2
aports-29ae0847ba2b4c11d474e9c8ff820b8f6b33afcd.tar.xz
main/py-hiredis: moved from testing
Diffstat (limited to 'main/py-hiredis/system-hiredis.patch')
-rw-r--r--main/py-hiredis/system-hiredis.patch39
1 files changed, 39 insertions, 0 deletions
diff --git a/main/py-hiredis/system-hiredis.patch b/main/py-hiredis/system-hiredis.patch
new file mode 100644
index 0000000000..57dc709b99
--- /dev/null
+++ b/main/py-hiredis/system-hiredis.patch
@@ -0,0 +1,39 @@
+--- a/setup.py
++++ b/setup.py
+@@ -21,27 +21,9 @@ class install_lib(_install_lib.install_lib):
+ if self.distribution.has_ext_modules():
+ self.run_command('build_ext')
+
+-# To link the extension with the C library, distutils passes the "-lLIBRARY"
+-# option to the linker. This makes it go through its library search path. If it
+-# finds a shared object of the specified library in one of the system-wide
+-# library paths, it will dynamically link it.
+-#
+-# We want the linker to statically link the version of hiredis that is included
+-# with hiredis-py. However, the linker may pick up the shared library version
+-# of hiredis, if it is available through one of the system-wide library paths.
+-# To prevent this from happening, we use an obfuscated library name such that
+-# the only version the linker will be able to find is the right version.
+-#
+-# This is a terrible hack, but patching distutils to do the right thing for all
+-# supported Python versions is worse...
+-#
+-# Also see: https://github.com/pietern/hiredis-py/issues/15
+-lib = ("hiredis_for_hiredis_py", {
+- "sources": ["vendor/hiredis/%s.c" % src for src in ("hiredis", "net", "sds")]})
+-
+ ext = Extension("hiredis.hiredis",
+ sources=glob.glob("src/*.c"),
+- include_dirs=["vendor"])
++ libraries=["hiredis"])
+
+ setup(
+ name="hiredis",
+@@ -53,7 +35,6 @@ setup(
+ keywords=["Redis"],
+ license="BSD",
+ packages=["hiredis"],
+- libraries=[lib],
+ ext_modules=[ext],
+
+ # Override "install_lib" command