aboutsummaryrefslogtreecommitdiffstats
path: root/main/py-httplib2
diff options
context:
space:
mode:
authorPeter Bui <pnutzh4x0r@gmail.com>2015-07-20 23:10:09 -0500
committerNatanael Copa <ncopa@alpinelinux.org>2015-07-21 06:10:50 +0000
commit4d9833ac86635dea45fc049c3942de8f4a1197db (patch)
tree320ec0a8574570697f19c953d184703533ce8e7f /main/py-httplib2
parent15216a1e4231f5d3f84dd3ecd632e26ebda7048a (diff)
downloadaports-4d9833ac86635dea45fc049c3942de8f4a1197db.tar.bz2
aports-4d9833ac86635dea45fc049c3942de8f4a1197db.tar.xz
main/py-httplib2: move from testing
Diffstat (limited to 'main/py-httplib2')
-rw-r--r--main/py-httplib2/APKBUILD42
1 files changed, 42 insertions, 0 deletions
diff --git a/main/py-httplib2/APKBUILD b/main/py-httplib2/APKBUILD
new file mode 100644
index 0000000000..c6fcd00387
--- /dev/null
+++ b/main/py-httplib2/APKBUILD
@@ -0,0 +1,42 @@
+# Contributor: Peter Bui <pnutzh4x0r@gmail.com>
+# Maintainer: Fabian Affolter <fabian@affolter-engineering.ch>
+pkgname=py-httplib2
+_pkgname=httplib2
+pkgver=0.9
+pkgrel=1
+pkgdesc="A Python HTTP client library"
+url="https://github.com/jcgregorio/httplib2"
+arch="noarch"
+license="MIT"
+depends="python"
+depends_dev=""
+makedepends="python-dev py-setuptools"
+install=""
+subpackages=""
+source="http://pypi.python.org/packages/source/${_pkgname:0:1}/$_pkgname/$_pkgname-$pkgver.tar.gz"
+
+_builddir="$srcdir"/$_pkgname-$pkgver
+prepare() {
+ local i
+ cd "$_builddir"
+ for i in $source; do
+ case $i in
+ *.patch) msg $i; patch -p1 -i "$srcdir"/$i || return 1;;
+ esac
+ done
+}
+
+build() {
+ cd "$_builddir"
+ python setup.py build || return 1
+}
+
+package() {
+ cd "$_builddir"
+ python setup.py install --prefix=/usr --root="$pkgdir" || return 1
+ chmod o+r $pkgdir/usr/lib/python2.7/site-packages/httplib2/cacerts.txt
+}
+
+md5sums="09d8e8016911fc40e2e4c58f1aa3ec24 httplib2-0.9.tar.gz"
+sha256sums="39ea8c6a6d9f595c177a16134fc49a990ad8d382758cbf469c8659662f2f51ab httplib2-0.9.tar.gz"
+sha512sums="51d90bfc6e95c482e42ef6ac8ab0ead6c3a83e4173b8db570eb738efa4c6b245726f60a99fa6680cee047c6db8ac1e689041847e7afebc022a2c10e50c99865e httplib2-0.9.tar.gz"