aboutsummaryrefslogtreecommitdiffstats
path: root/main/py-setuptools
diff options
context:
space:
mode:
authorTimo Teräs <timo.teras@iki.fi>2016-07-19 10:37:17 +0300
committerTimo Teräs <timo.teras@iki.fi>2016-07-19 10:37:59 +0300
commit35b6be4c5f0534846bdddb9e31c753db400bbbe9 (patch)
tree691eb9b51c28bdcbd83f968764727bddc6808fa7 /main/py-setuptools
parent6edce501202715bd83b2bd1d5eff7f9c0bd4d5cf (diff)
downloadaports-35b6be4c5f0534846bdddb9e31c753db400bbbe9.tar.bz2
aports-35b6be4c5f0534846bdddb9e31c753db400bbbe9.tar.xz
main/py-setuptools: upgrade to 24.0.3 and apply hotfix
Diffstat (limited to 'main/py-setuptools')
-rw-r--r--main/py-setuptools/APKBUILD14
-rw-r--r--main/py-setuptools/fix-659.patch44
2 files changed, 53 insertions, 5 deletions
diff --git a/main/py-setuptools/APKBUILD b/main/py-setuptools/APKBUILD
index 5475fc5280..ff7b9bf09c 100644
--- a/main/py-setuptools/APKBUILD
+++ b/main/py-setuptools/APKBUILD
@@ -2,7 +2,7 @@
# Maintainer: Fabian Affolter <fabian@affolter-engineering.ch>
pkgname=py-setuptools
_pkgname=${pkgname#py-}
-pkgver=24.0.2
+pkgver=24.0.3
pkgrel=0
pkgdesc="A collection of enhancements to the Python distutils"
url="http://pypi.python.org/pypi/setuptools"
@@ -12,7 +12,8 @@ depends="python"
makedepends="python-dev"
install=""
subpackages=""
-source="${_pkgname}-${pkgver}.tar.gz::https://github.com/pypa/${_pkgname}/archive/v${pkgver}.tar.gz"
+source="${_pkgname}-${pkgver}.tar.gz::https://github.com/pypa/${_pkgname}/archive/v${pkgver}.tar.gz
+ fix-659.patch"
builddir="$srcdir"/$_pkgname-$pkgver
@@ -29,6 +30,9 @@ package() {
rm -f "$pkgdir"/usr/bin/easy_install || return 1
}
-md5sums="65013a19268df4629caa1cb0071b32f0 setuptools-24.0.2.tar.gz"
-sha256sums="8f61297dde9f8b5017c1e18aea4f9865c4a25f2ef3c77975aff783024bb05a99 setuptools-24.0.2.tar.gz"
-sha512sums="f3e09a97a3602fe83d26d053e32b962da6f03524583e2271ca609deaa9b74cbfb94d0fc12ffbe9d03d3f75fa126d6d78a186c2190837653048aa6e4d67b75dae setuptools-24.0.2.tar.gz"
+md5sums="11472d17f777b83757681d0608ae9aee setuptools-24.0.3.tar.gz
+d17f39a9f6d975d2e6e46c0aa875ed67 fix-659.patch"
+sha256sums="b342d2d457a678d558e51aaab79640360d350b0044816259b3085e079adcbdcf setuptools-24.0.3.tar.gz
+fa08bd5496d05cce655b745f6d99381153b114fb285272e07504949ec0d41077 fix-659.patch"
+sha512sums="f664e1feb417e2eb0f8658ee0f2cb3b308b3e11d5dde6b67cefc7549b0693be268343fd508e654ea0b8080658373d260e537b54ec18499c35e078fd6b79de952 setuptools-24.0.3.tar.gz
+c6495875aef65896a4017d8426b8ef6fd25c1993751e8ef531520f9ed5561d55b43b80b3e12897a598110a6190b6fa788bcd459d6c5871b83db32596b712591f fix-659.patch"
diff --git a/main/py-setuptools/fix-659.patch b/main/py-setuptools/fix-659.patch
new file mode 100644
index 0000000000..4035541df1
--- /dev/null
+++ b/main/py-setuptools/fix-659.patch
@@ -0,0 +1,44 @@
+https://github.com/pypa/setuptools/issues/659
+
+diff -ru setuptools-24.0.2.orig/pkg_resources/__init__.py setuptools-24.0.2/pkg_resources/__init__.py
+--- setuptools-24.0.2.orig/pkg_resources/__init__.py 2016-07-04 18:22:36.000000000 +0300
++++ setuptools-24.0.2/pkg_resources/__init__.py 2016-07-19 10:33:34.030885550 +0300
+@@ -988,9 +988,9 @@
+ """
+ extra_evals = (
+ req.marker.evaluate({'extra': extra})
+- for extra in self.get(req, ()) + (None,)
++ for extra in self.get(req, ())
+ )
+- return not req.marker or any(extra_evals)
++ return not req.marker or any(extra_evals) or req.marker.evaluate()
+
+
+ class Environment(object):
+diff -ru setuptools-24.0.2.orig/pkg_resources/tests/test_resources.py setuptools-24.0.2/pkg_resources/tests/test_resources.py
+--- setuptools-24.0.2.orig/pkg_resources/tests/test_resources.py 2016-07-04 18:22:36.000000000 +0300
++++ setuptools-24.0.2/pkg_resources/tests/test_resources.py 2016-07-19 10:33:34.030885550 +0300
+@@ -189,7 +189,7 @@
+ def test_environment_marker_evaluation_called(self):
+ """
+ If one package foo requires bar without any extras,
+- markers should pass for bar without extras.
++ markers should pass for bar.
+ """
+ parent_req, = parse_requirements("foo")
+ req, = parse_requirements("bar;python_version>='2'")
+@@ -201,6 +201,14 @@
+ req_extras = pkg_resources._ReqExtras({req: parent_req.extras})
+ assert req_extras.markers_pass(req)
+
++ # extra should not be present in the marker namespace if
++ # no markers were supplied
++ parent_req, = parse_requirements("foo")
++ req, = parse_requirements("bar;extra==''")
++ req_extras = pkg_resources._ReqExtras({req: parent_req.extras})
++ with pytest.raises(packaging.markers.UndefinedEnvironmentName):
++ req_extras.markers_pass(req)
++
+ def test_marker_evaluation_with_extras(self):
+ """Extras are also evaluated as markers at resolution time."""
+ ad = pkg_resources.Environment([])