aboutsummaryrefslogtreecommitdiffstats
path: root/main/py-sortedcontainers/APKBUILD
diff options
context:
space:
mode:
authorLeonardo Arena <rnalrd@alpinelinux.org>2019-06-11 06:06:29 +0000
committerLeonardo Arena <rnalrd@alpinelinux.org>2019-07-15 09:57:55 +0000
commit39704ca8de5ece9a335b16502e72543aff9993ce (patch)
tree675fc52f05f5194c158a764388f1ea3b3dabf098 /main/py-sortedcontainers/APKBUILD
parent61747ef7247b4805f9881eedd113c538e156376d (diff)
downloadaports-39704ca8de5ece9a335b16502e72543aff9993ce.tar.bz2
aports-39704ca8de5ece9a335b16502e72543aff9993ce.tar.xz
main/py-sortedcontainers: backported from 3.10
Needed by py3-fakeredis
Diffstat (limited to 'main/py-sortedcontainers/APKBUILD')
-rw-r--r--main/py-sortedcontainers/APKBUILD52
1 files changed, 52 insertions, 0 deletions
diff --git a/main/py-sortedcontainers/APKBUILD b/main/py-sortedcontainers/APKBUILD
new file mode 100644
index 0000000000..f1e4b67ccd
--- /dev/null
+++ b/main/py-sortedcontainers/APKBUILD
@@ -0,0 +1,52 @@
+# Contributor: André Klitzing <aklitzing@gmail.com>
+# Maintainer: André Klitzing <aklitzing@gmail.com>
+pkgname=py-sortedcontainers
+_pkgname=sortedcontainers
+pkgver=2.0.4
+pkgrel=0
+pkgdesc="Python library for sorting collections and containers"
+url="http://www.grantjenks.com/docs/sortedcontainers"
+arch="noarch"
+license="Apache-2.0"
+makedepends="py-setuptools python2-dev python3-dev"
+checkdepends="py-nose pytest"
+subpackages="py2-$_pkgname:_py2 py3-$_pkgname:_py3"
+source="https://files.pythonhosted.org/packages/source/${_pkgname:0:1}/$_pkgname/$_pkgname-$pkgver.tar.gz"
+builddir="$srcdir"/$_pkgname-$pkgver
+
+build() {
+ cd "$builddir"
+ python2 setup.py build
+ python3 setup.py build
+}
+
+check() {
+ cd "$builddir"
+ nosetests-2.7
+ nosetests-3.6
+}
+
+package() {
+ mkdir -p "$pkgdir"
+}
+
+_py2() {
+ replaces="$pkgname"
+ _py python2
+}
+
+_py3() {
+ _py python3
+}
+
+_py() {
+ local python="$1"
+ pkgdesc="$pkgdesc (for $python)"
+ depends="$python"
+ install_if="$pkgname=$pkgver-r$pkgrel $python"
+
+ cd "$builddir"
+ $python setup.py install --prefix=/usr --root="$subpkgdir"
+}
+
+sha512sums="e6adde0bd0983d537823c50c8e862cc6dae2ae4b4d9a84e1ca78637825a14b64519764cf5b8981365d193797ff8b8fa830fddcd7f757244ff9bedb34e932b736 sortedcontainers-2.0.4.tar.gz"