aboutsummaryrefslogtreecommitdiffstats
path: root/main/py-twitter
diff options
context:
space:
mode:
authorPeter Bui <pnutzh4x0r@gmail.com>2015-07-20 23:35:55 -0500
committerNatanael Copa <ncopa@alpinelinux.org>2015-07-21 06:10:51 +0000
commitee4eec5de1f815ad278f5eb4cdcc2c9bfe6bfff9 (patch)
tree455627a88ede0b9087cc155245089c2921d8a3a4 /main/py-twitter
parentc25102d2c9dcabacbd722f22ab786be4f72d947a (diff)
downloadaports-ee4eec5de1f815ad278f5eb4cdcc2c9bfe6bfff9.tar.bz2
aports-ee4eec5de1f815ad278f5eb4cdcc2c9bfe6bfff9.tar.xz
main/py-twitter: move from testing
Diffstat (limited to 'main/py-twitter')
-rw-r--r--main/py-twitter/APKBUILD40
1 files changed, 40 insertions, 0 deletions
diff --git a/main/py-twitter/APKBUILD b/main/py-twitter/APKBUILD
new file mode 100644
index 0000000000..e4ec519cfe
--- /dev/null
+++ b/main/py-twitter/APKBUILD
@@ -0,0 +1,40 @@
+# Maintainer: Peter Bui <pnutzh4x0r@gmail.com>
+pkgname=py-twitter
+_pkgname=python-twitter
+pkgver=2.2
+pkgrel=0
+pkgdesc="Python wrapper around the Twitter API'"
+url="https://pypi.python.org/pypi/python-twitter"
+arch="noarch"
+license="Apache"
+depends="python py-httplib2 py-simplejson py-oauth2 py-requests-oauthlib"
+depends_dev="python-dev py-setuptools"
+makedepends="$depends_dev"
+install=""
+subpackages=""
+source="http://pypi.python.org/packages/source/${_pkgname:0:1}/$_pkgname/$_pkgname-$pkgver.tar.gz"
+
+_builddir="$srcdir"/$_pkgname-$pkgver
+prepare() {
+ local i
+ cd "$_builddir"
+ for i in $source; do
+ case $i in
+ *.patch) msg $i; patch -p1 -i "$srcdir"/$i || return 1;;
+ esac
+ done
+}
+
+build() {
+ cd "$_builddir"
+ python setup.py build || return 1
+}
+
+package() {
+ cd "$_builddir"
+ python setup.py install --prefix=/usr --root="$pkgdir" || return 1
+}
+
+md5sums="eab697b3a9bc6bf3432d09a489f4ed8b python-twitter-2.2.tar.gz"
+sha256sums="b70648c6026ef3772a1c911382d9fd8651fe0b673c15aad7d38d6f685c7c4dc2 python-twitter-2.2.tar.gz"
+sha512sums="5c9cf15fd540f8a157d1f8c292651e6f1191850d571da3b22c8fb732c3ae4fd7fdd29f9286532698fc50a43b9540cef36fc05a8858db49a9d92246629a697ca1 python-twitter-2.2.tar.gz"