aboutsummaryrefslogtreecommitdiffstats
path: root/main/py-uritemplate
diff options
context:
space:
mode:
authorJakub Jirutka <jakub@jirutka.cz>2017-12-30 14:43:53 +0100
committerJakub Jirutka <jakub@jirutka.cz>2017-12-30 14:52:56 +0100
commitaa2874232ba43e4292685cc240ba391af513d766 (patch)
tree8c0f0e271ee7aea86697e040a60da724294ce02d /main/py-uritemplate
parentb3f9e7f5067bc690ed5d35083610e20157696bf7 (diff)
downloadaports-aa2874232ba43e4292685cc240ba391af513d766.tar.bz2
aports-aa2874232ba43e4292685cc240ba391af513d766.tar.xz
main/py-uritemplate: fix name of subpackages
pyX-uritemplate.py -> pyX-uritemplate
Diffstat (limited to 'main/py-uritemplate')
-rw-r--r--main/py-uritemplate/APKBUILD11
1 files changed, 7 insertions, 4 deletions
diff --git a/main/py-uritemplate/APKBUILD b/main/py-uritemplate/APKBUILD
index eab84c174f..5555a44783 100644
--- a/main/py-uritemplate/APKBUILD
+++ b/main/py-uritemplate/APKBUILD
@@ -3,15 +3,15 @@
pkgname=py-uritemplate
_pkgname=uritemplate.py
pkgver=3.0.0
-pkgrel=0
+pkgrel=1
pkgdesc="Python module to use URO templates"
-url=" https://uritemplate.readthedocs.org"
+url="https://uritemplate.readthedocs.org"
arch="noarch"
license="BSD"
options="!check"
depends=""
makedepends="python2-dev python3-dev py-setuptools"
-subpackages="py3-$_pkgname:_py3 py2-$_pkgname:_py2"
+subpackages="py3-${pkgname#py-}:_py3 py2-${pkgname#py-}:_py2"
source="https://files.pythonhosted.org/packages/source/${_pkgname:0:1}/$_pkgname/$_pkgname-$pkgver.tar.gz"
builddir="$srcdir/$_pkgname-$pkgver"
@@ -36,11 +36,14 @@ _py() {
}
_py2() {
- replaces="$pkgname"
+ replaces="$pkgname py2-$_pkgname" # for backward compatibility
+ provides="py2-$_pkgname" # for backward compatibility
_py python2
}
_py3() {
+ replaces="py3-$_pkgname" # for backward compatibility
+ provides="py3-$_pkgname" # for backward compatibility
_py python3
}