aboutsummaryrefslogtreecommitdiffstats
path: root/main/python2/APKBUILD
diff options
context:
space:
mode:
authorBartłomiej Piotrowski <b@bpiotrowski.pl>2016-07-18 19:37:02 +0200
committerBartłomiej Piotrowski <b@bpiotrowski.pl>2016-07-18 19:37:02 +0200
commitc80d1d64bd1eb7956d53caed0c9f91a848a7e83f (patch)
tree9b3838f655e919f8bb48be7dac34dada060822d4 /main/python2/APKBUILD
parent99dd043cd563c7919bb11bd2478a9e0f9a3dd1c0 (diff)
downloadaports-c80d1d64bd1eb7956d53caed0c9f91a848a7e83f.tar.bz2
aports-c80d1d64bd1eb7956d53caed0c9f91a848a7e83f.tar.xz
main/python2: use builddir
Diffstat (limited to 'main/python2/APKBUILD')
-rw-r--r--main/python2/APKBUILD6
1 files changed, 4 insertions, 2 deletions
diff --git a/main/python2/APKBUILD b/main/python2/APKBUILD
index 2ef5515e3a..6198149ac2 100644
--- a/main/python2/APKBUILD
+++ b/main/python2/APKBUILD
@@ -16,6 +16,8 @@ makedepends="expat-dev openssl-dev zlib-dev ncurses-dev bzip2-dev
source="http://www.$pkgname.org/ftp/$pkgname/$pkgver/Python-$pkgver.tar.xz
musl-find_library.patch
unchecked-ioctl.patch"
+builddir="$srcdir/Python-$pkgver"
+
prepare() {
default_prepare
@@ -32,7 +34,7 @@ prepare() {
}
build() {
- cd "$srcdir/Python-$pkgver"
+ cd "$builddir"
export OPT="$CFLAGS"
./configure \
--build=$CBUILD \
@@ -50,7 +52,7 @@ build() {
}
package() {
- cd "$srcdir/Python-$pkgver"
+ cd "$builddir"
make -j1 DESTDIR="$pkgdir" install || return 1
install -Dm644 LICENSE "$pkgdir"/usr/share/licenses/$pkgname/LICENSE
rm "$pkgdir/usr/bin/2to3" || return 1