aboutsummaryrefslogtreecommitdiffstats
path: root/main/python2
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2016-10-26 12:28:45 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2016-10-26 12:42:33 +0000
commitec356aebd5adedb9de23cbb54ff42a783fb835e7 (patch)
tree3d5d9547461536638cad6966d89d7a5546111c54 /main/python2
parentdddfa696dcbef80b8169cb1079eef23cbbd25491 (diff)
downloadaports-ec356aebd5adedb9de23cbb54ff42a783fb835e7.tar.bz2
aports-ec356aebd5adedb9de23cbb54ff42a783fb835e7.tar.xz
main/python2: fix cyclic dependency for tkinter
Add a separate apkbuild for tkinter to avoid the cyclic buildtime dependency: python -> tk -> libX11 -> libxcb -> xcb-proto -> python
Diffstat (limited to 'main/python2')
-rw-r--r--main/python2/APKBUILD15
1 files changed, 1 insertions, 14 deletions
diff --git a/main/python2/APKBUILD b/main/python2/APKBUILD
index 7f0e26a21d..37b9de2aa2 100644
--- a/main/python2/APKBUILD
+++ b/main/python2/APKBUILD
@@ -2,7 +2,7 @@
pkgname=python2
pkgver=2.7.12
_verbase=${pkgver%.*}
-pkgrel=4
+pkgrel=5
pkgdesc="A high-level scripting language"
url="http://www.python.org"
arch="all"
@@ -18,12 +18,6 @@ source="http://www.python.org/ftp/python/$pkgver/Python-$pkgver.tar.xz
unchecked-ioctl.patch"
builddir="$srcdir/Python-$pkgver"
-# To avoid circular dependency between python2 and x11 when bootstrapping.
-if [ -z "$BOOTSTRAP" ]; then
- subpackages="$subpackages py2-tkinter:tkinter"
- makedepends="$makedepends tk tk-dev"
-fi
-
prepare() {
default_prepare || return 1
@@ -104,13 +98,6 @@ gdbm() {
_mv_files $(find usr/lib -name '*gdbm*')
}
-tkinter() {
- pkgdesc="A graphical user interface for the Python"
- replaces="py-tkinter"
-
- _mv_files usr/lib/python$_verbase/lib-dynload/_tkinter.so
-}
-
md5sums="57dffcee9cee8bb2ab5f82af1d8e9a69 Python-2.7.12.tar.xz
e2ea88671f8f838142323aedc417be48 musl-find_library.patch
dada786a50fa332686a9b9260d84c110 unchecked-ioctl.patch"