aboutsummaryrefslogtreecommitdiffstats
path: root/main/python3
diff options
context:
space:
mode:
authorTimo Teräs <timo.teras@iki.fi>2016-11-25 11:33:31 +0000
committerTimo Teräs <timo.teras@iki.fi>2016-11-25 11:33:31 +0000
commit9b5e0807a78842ef7c6dc0b3a813dd45026cda56 (patch)
treeab34ddc20dbbc1ddfa1f4b0e13292c6479c47a7c /main/python3
parent8d77f2104e8c20f4814cd44e1e446f9bd2f19454 (diff)
downloadaports-9b5e0807a78842ef7c6dc0b3a813dd45026cda56.tar.bz2
aports-9b5e0807a78842ef7c6dc0b3a813dd45026cda56.tar.xz
main/python3: fix python3 to not depend on python3-dev
the dependency was picked up by the symlink pointing to another symlink inside -dev package. expand it so the symlink in the main package points directly to the DSO.
Diffstat (limited to 'main/python3')
-rw-r--r--main/python3/APKBUILD4
1 files changed, 2 insertions, 2 deletions
diff --git a/main/python3/APKBUILD b/main/python3/APKBUILD
index eeaf9280d1..d5b1c6c4f6 100644
--- a/main/python3/APKBUILD
+++ b/main/python3/APKBUILD
@@ -4,7 +4,7 @@
pkgname=python3
pkgver=3.5.2
_basever="${pkgver%.*}"
-pkgrel=7
+pkgrel=8
pkgdesc="A high-level scripting language"
url="http://www.python.org"
arch="all"
@@ -58,7 +58,7 @@ package() {
|| return 1
install -Dm644 LICENSE "$pkgdir"/usr/share/licenses/$pkgname/LICENSE
- ln -sf ../../libpython${_basever}m.so \
+ ln -sf ../../$(readlink ${pkgdir}/usr/lib/libpython${_basever}m.so) \
"${pkgdir}/usr/lib/python${_basever}/config-${_basever}m/libpython${_basever}m.so"
}